{"answers":{"affected":"2 open source packages ship an affected version, including shopware/shopware.","exploited":"There is no known exploitation of GHSA-6gv9-7q4g-pmvm in the wild and no public exploit code.","fix":"Upgrade shopware/shopware to 5.6.9 or later.","what":"GHSA-6gv9-7q4g-pmvm is a cross-site scripting vulnerability in shopware/shopware, published on 13 Nov 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-6gv9-7q4g-pmvm and fix it if it is affected.\n\nWhat it is: GHSA-6gv9-7q4g-pmvm is a cross-site scripting vulnerability in shopware/shopware, published on 13 Nov 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-6gv9-7q4g-pmvm in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- shopware/shopware (Packagist): affected all versions; fixed in 5.6.9\n- shopware/shopware (Packagist): affected all versions; fixed in 5.6.9\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-6gv9-7q4g-pmvm/ (Markdown: https://insights.sbomify.com/GHSA-6gv9-7q4g-pmvm/index.md)","id":"GHSA-6gv9-7q4g-pmvm","markdown":"https://insights.sbomify.com/GHSA-6gv9-7q4g-pmvm/index.md","name":"GHSA-6gv9-7q4g-pmvm","record":{"aliases":[],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Shopware e-commerce platform","requires_auth":"low_privilege","summary":"Attackers can inject persistent scripts into the customer module, potentially stealing data or hijacking accounts; users should upgrade Shopware.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\nPersistent XSS in customer  module\n\n### Patches\n\nWe recommend updating to the current version 5.6.9. You can get the update to 5.6.9 regularly via the Auto-Updater or directly via the download overview.\n\nFor older versions you can use the Security Plugin:\nhttps://store.shopware.com/en/swag575294366635f/shopware-security-plugin.html\n\n### References\nhttps://docs.shopware.com/en/shopware-5-en/security-updates/security-update-11-2020","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Persistent XSS in customer module in Shopware","id":"GHSA-6gv9-7q4g-pmvm","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2020"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["5.6.9"],"introduced":["0"],"last_affected":[],"package":"shopware/shopware","purl":null,"source":"GHSA-6gv9-7q4g-pmvm"},{"ecosystem":"Packagist","fixed":["5.6.9"],"introduced":["0"],"last_affected":[],"package":"shopware/shopware","purl":"pkg:composer/shopware/shopware","source":"GHSA-6gv9-7q4g-pmvm"}],"products":null,"published":"2020-11-13","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can inject persistent scripts into the customer module, potentially stealing data or hijacking accounts; users should upgrade Shopware.","url":"https://insights.sbomify.com/GHSA-6gv9-7q4g-pmvm/"}