# GHSA-6hcf-g6gr-hhcr: `openssl` `X509Extension::new` and `X509Extension::new_nid` null pointer dereference

> A null pointer dereference in the Rust OpenSSL bindings causes a crash when specific extension types are used with a missing context.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Mar 2023
- **Also known as:** RUSTSEC-2023-0024

## What is GHSA-6hcf-g6gr-hhcr?

GHSA-6hcf-g6gr-hhcr is a vulnerability in openssl, published on 24 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

These functions would crash when the context argument was None with certain extension types.

Thanks to David Benjamin (Google) for reporting this issue.

## Which versions are affected by GHSA-6hcf-g6gr-hhcr?

3 open source packages ship an affected version, including openssl.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openssl` | crates.io | From 0.0.0-0 | 0.10.48 |
| `openssl` | crates.io | From 0.9.7 | 0.10.48 |
| `openssl` | crates.io | From 0.9.7 | 0.10.48 |

## How do I fix GHSA-6hcf-g6gr-hhcr?

Upgrade openssl to 0.10.48 or later.

## Is GHSA-6hcf-g6gr-hhcr being exploited?

There is no known exploitation of GHSA-6hcf-g6gr-hhcr in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-6hcf-g6gr-hhcr and fix it if it is affected.

What it is: GHSA-6hcf-g6gr-hhcr is a vulnerability in openssl, published on 24 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-6hcf-g6gr-hhcr in the wild and no public exploit code.

Affected packages and fixed versions:
- openssl (crates.io): affected from 0.0.0-0; fixed in 0.10.48
- openssl (crates.io): affected from 0.9.7; fixed in 0.10.48
- openssl (crates.io): affected from 0.9.7; fixed in 0.10.48

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-6hcf-g6gr-hhcr/ (Markdown: https://insights.sbomify.com/GHSA-6hcf-g6gr-hhcr/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-6hcf-g6gr-hhcr

---
From sbomify Insights: https://insights.sbomify.com/GHSA-6hcf-g6gr-hhcr/
Summaries are generated and may contain mistakes; the official description above is the record.
