{"answers":{"affected":"2 open source packages ship an affected version, including laravel/framework.","exploited":"There is no known exploitation of GHSA-6jvx-8ch9-j2jr in the wild and no public exploit code.","fix":"Upgrade laravel/framework to 5.6.30 or later.","what":"GHSA-6jvx-8ch9-j2jr is an unsafe deserialization vulnerability in laravel/framework, published on 15 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-6jvx-8ch9-j2jr and fix it if it is affected.\n\nWhat it is: GHSA-6jvx-8ch9-j2jr is an unsafe deserialization vulnerability in laravel/framework, published on 15 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-6jvx-8ch9-j2jr in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- laravel/framework (Packagist): affected from 5.5.0; fixed in 5.6.30\n- laravel/framework (Packagist): affected from 5.5.0; fixed in 5.6.30\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-6jvx-8ch9-j2jr/ (Markdown: https://insights.sbomify.com/GHSA-6jvx-8ch9-j2jr/index.md)","id":"GHSA-6jvx-8ch9-j2jr","markdown":"https://insights.sbomify.com/GHSA-6jvx-8ch9-j2jr/index.md","name":"GHSA-6jvx-8ch9-j2jr","record":{"aliases":[],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Laravel framework","requires_auth":"none","summary":"An attacker can exploit insecure cookie deserialization in Laravel to execute arbitrary code, requiring an immediate framework upgrade.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Laravel 5.6.30 is a security release of Laravel and is recommended as an immediate upgrade for all users. Laravel 5.6.30 also contains a breaking change to cookie encryption and serialization logic. Refer to [laravel advisory](https://laravel.com/docs/5.6/upgrade#upgrade-5.6.30) for more details and read the notes carefully when upgrading your application.","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Laravel Cookie serialization vulnerability","id":"GHSA-6jvx-8ch9-j2jr","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"deserialization","year":"2024"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["5.6.30"],"introduced":["5.5.0"],"last_affected":[],"package":"laravel/framework","purl":null,"source":"GHSA-6jvx-8ch9-j2jr"},{"ecosystem":"Packagist","fixed":["5.6.30"],"introduced":["5.5.0"],"last_affected":[],"package":"laravel/framework","purl":"pkg:composer/laravel/framework","source":"GHSA-6jvx-8ch9-j2jr"}],"products":null,"published":"2024-05-15","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An attacker can exploit insecure cookie deserialization in Laravel to execute arbitrary code, requiring an immediate framework upgrade.","url":"https://insights.sbomify.com/GHSA-6jvx-8ch9-j2jr/"}