# GHSA-6jvx-8ch9-j2jr: Laravel Cookie serialization vulnerability

> An attacker can exploit insecure cookie deserialization in Laravel to execute arbitrary code, requiring an immediate framework upgrade.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 May 2024

## What is GHSA-6jvx-8ch9-j2jr?

GHSA-6jvx-8ch9-j2jr is an unsafe deserialization vulnerability in laravel/framework, published on 15 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Laravel 5.6.30 is a security release of Laravel and is recommended as an immediate upgrade for all users. Laravel 5.6.30 also contains a breaking change to cookie encryption and serialization logic. Refer to [laravel advisory](https://laravel.com/docs/5.6/upgrade#upgrade-5.6.30) for more details and read the notes carefully when upgrading your application.

## Which versions are affected by GHSA-6jvx-8ch9-j2jr?

2 open source packages ship an affected version, including laravel/framework.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `laravel/framework` | Packagist | From 5.5.0 | 5.6.30 |
| `laravel/framework` | Packagist | From 5.5.0 | 5.6.30 |

## How do I fix GHSA-6jvx-8ch9-j2jr?

Upgrade laravel/framework to 5.6.30 or later.

## Is GHSA-6jvx-8ch9-j2jr being exploited?

There is no known exploitation of GHSA-6jvx-8ch9-j2jr in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-6jvx-8ch9-j2jr and fix it if it is affected.

What it is: GHSA-6jvx-8ch9-j2jr is an unsafe deserialization vulnerability in laravel/framework, published on 15 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-6jvx-8ch9-j2jr in the wild and no public exploit code.

Affected packages and fixed versions:
- laravel/framework (Packagist): affected from 5.5.0; fixed in 5.6.30
- laravel/framework (Packagist): affected from 5.5.0; fixed in 5.6.30

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-6jvx-8ch9-j2jr/ (Markdown: https://insights.sbomify.com/GHSA-6jvx-8ch9-j2jr/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-6jvx-8ch9-j2jr

---
From sbomify Insights: https://insights.sbomify.com/GHSA-6jvx-8ch9-j2jr/
Summaries are generated and may contain mistakes; the official description above is the record.
