{"answers":{"affected":"2 open source packages ship an affected version, including friendsofsymfony/user-bundle.","exploited":"There is no known exploitation of GHSA-6mjq-9x4w-m3w9 in the wild and no public exploit code.","fix":"Upgrade friendsofsymfony/user-bundle to 1.2.4 or later.","what":"GHSA-6mjq-9x4w-m3w9 is an authentication bypass vulnerability in friendsofsymfony/user-bundle, published on 15 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-6mjq-9x4w-m3w9 and fix it if it is affected.\n\nWhat it is: GHSA-6mjq-9x4w-m3w9 is an authentication bypass vulnerability in friendsofsymfony/user-bundle, published on 15 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-6mjq-9x4w-m3w9 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- friendsofsymfony/user-bundle (Packagist): affected from 1.2.0; fixed in 1.2.4\n- friendsofsymfony/user-bundle (Packagist): affected from 1.2.0; fixed in 1.2.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-6mjq-9x4w-m3w9/ (Markdown: https://insights.sbomify.com/GHSA-6mjq-9x4w-m3w9/index.md)","id":"GHSA-6mjq-9x4w-m3w9","markdown":"https://insights.sbomify.com/GHSA-6mjq-9x4w-m3w9/index.md","name":"GHSA-6mjq-9x4w-m3w9","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Symfony User Bundle","requires_auth":"none","summary":"Attackers can hijack user sessions in FOSUserBundle, leading to account takeover; users should upgrade to the latest version.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Versions of FOSUserBundle from 1.2.x to 1.2.4 have been found to contain a security vulnerability related to session hijacking. This issue has been addressed in version 1.2.4, and users are strongly advised to upgrade to the latest version to prevent potential session-related security risks.","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"FOSUserBundle Session Hijacking Vulnerability","id":"GHSA-6mjq-9x4w-m3w9","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"auth_bypass","year":"2024"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["1.2.4"],"introduced":["1.2.0"],"last_affected":[],"package":"friendsofsymfony/user-bundle","purl":null,"source":"GHSA-6mjq-9x4w-m3w9"},{"ecosystem":"Packagist","fixed":["1.2.4"],"introduced":["1.2.0"],"last_affected":[],"package":"friendsofsymfony/user-bundle","purl":"pkg:composer/friendsofsymfony/user-bundle","source":"GHSA-6mjq-9x4w-m3w9"}],"products":null,"published":"2024-05-15","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can hijack user sessions in FOSUserBundle, leading to account takeover; users should upgrade to the latest version.","url":"https://insights.sbomify.com/GHSA-6mjq-9x4w-m3w9/"}