{"answers":{"affected":"3 open source packages ship an affected version, including certifi.","exploited":"There is no known exploitation of GHSA-6q48-6c7w-9gw2 in the wild and no public exploit code.","fix":"Upgrade certifi to a fixed version for your release line: 2026.10.18 or 2026.10.19.","what":"GHSA-6q48-6c7w-9gw2 is a vulnerability in certifi, published on 20 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-6q48-6c7w-9gw2 and fix it if it is affected.\n\nWhat it is: GHSA-6q48-6c7w-9gw2 is a vulnerability in certifi, published on 20 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-6q48-6c7w-9gw2 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- certifi (PyPI): affected from 2019.03.09; fixed in 2026.10.18\n- certifi (PyPI): affected from 2019.03.09; fixed in 2026.10.18\n- certifi (PyPI): affected from 2019.03.09; fixed in 2026.10.19\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-6q48-6c7w-9gw2/ (Markdown: https://insights.sbomify.com/GHSA-6q48-6c7w-9gw2/index.md)","id":"GHSA-6q48-6c7w-9gw2","markdown":"https://insights.sbomify.com/GHSA-6q48-6c7w-9gw2/index.md","name":"GHSA-6q48-6c7w-9gw2","record":{"aliases":["PYSEC-2026-4320"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Python CA bundle","requires_auth":"none","summary":"Attackers with compromised keys can issue valid certificates to intercept or modify TLS traffic for applications using the certifi library.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Certifi versions before 2026.10.18 include the `emSign ECC Root CA - G3` root certificate in their bundled CA store. Eight eMudhra intermediate CA certificates that chain to this root have compromised private keys and the CA has revoked them. \n\nAn attacker with one of the compromised keys can issue valid-looking certificates for any hostname. If the attacker is also on-path, they can intercept or modify TLS traffic from clients that trust the certifi bundle. Examples include `requests`, `urllib3` and `pip`, and the Python.org macOS installer.\n\nCertifi 2026.10.18 removed all emSign roots from the bundle. Certifi 2026.10.19 restored the emSign roots that are not affected. Upgrade to 2026.10.19 or later, and rebuild container images that vendor certifi.","ecosystems":["PyPI"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"certifi bundles emSign root CAs with compromised intermediate CA keys","id":"GHSA-6q48-6c7w-9gw2","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"weak_cryptography","year":"2026"},"n_packages":3,"n_references":null,"packages":[{"ecosystem":"PyPI","fixed":["2026.10.18"],"introduced":["2019.03.09"],"last_affected":[],"package":"certifi","purl":null,"source":"GHSA-6q48-6c7w-9gw2"},{"ecosystem":"PyPI","fixed":["2026.10.18"],"introduced":["2019.03.09"],"last_affected":[],"package":"certifi","purl":"pkg:pypi/certifi","source":"GHSA-6q48-6c7w-9gw2"},{"ecosystem":"PyPI","fixed":["2026.10.19"],"introduced":["2019.03.09"],"last_affected":[],"package":"certifi","purl":"pkg:pypi/certifi","source":"PYSEC-2026-4320"}],"products":null,"published":"2026-10-20","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers with compromised keys can issue valid certificates to intercept or modify TLS traffic for applications using the certifi library.","url":"https://insights.sbomify.com/GHSA-6q48-6c7w-9gw2/"}