# GHSA-6q48-6c7w-9gw2: certifi bundles emSign root CAs with compromised intermediate CA keys

> Attackers with compromised keys can issue valid certificates to intercept or modify TLS traffic for applications using the certifi library.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Oct 2026
- **Also known as:** PYSEC-2026-4320

## What is GHSA-6q48-6c7w-9gw2?

GHSA-6q48-6c7w-9gw2 is a vulnerability in certifi, published on 20 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Certifi versions before 2026.10.18 include the `emSign ECC Root CA - G3` root certificate in their bundled CA store. Eight eMudhra intermediate CA certificates that chain to this root have compromised private keys and the CA has revoked them. 

An attacker with one of the compromised keys can issue valid-looking certificates for any hostname. If the attacker is also on-path, they can intercept or modify TLS traffic from clients that trust the certifi bundle. Examples include `requests`, `urllib3` and `pip`, and the Python.org macOS installer.

Certifi 2026.10.18 removed all emSign roots from the bundle. Certifi 2026.10.19 restored the emSign roots that are not affected. Upgrade to 2026.10.19 or later, and rebuild container images that vendor certifi.

## Which versions are affected by GHSA-6q48-6c7w-9gw2?

3 open source packages ship an affected version, including certifi.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `certifi` | PyPI | From 2019.03.09 | 2026.10.18 |
| `certifi` | PyPI | From 2019.03.09 | 2026.10.18 |
| `certifi` | PyPI | From 2019.03.09 | 2026.10.19 |

## How do I fix GHSA-6q48-6c7w-9gw2?

Upgrade certifi to a fixed version for your release line: 2026.10.18 or 2026.10.19.

## Is GHSA-6q48-6c7w-9gw2 being exploited?

There is no known exploitation of GHSA-6q48-6c7w-9gw2 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-6q48-6c7w-9gw2 and fix it if it is affected.

What it is: GHSA-6q48-6c7w-9gw2 is a vulnerability in certifi, published on 20 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-6q48-6c7w-9gw2 in the wild and no public exploit code.

Affected packages and fixed versions:
- certifi (PyPI): affected from 2019.03.09; fixed in 2026.10.18
- certifi (PyPI): affected from 2019.03.09; fixed in 2026.10.18
- certifi (PyPI): affected from 2019.03.09; fixed in 2026.10.19

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-6q48-6c7w-9gw2/ (Markdown: https://insights.sbomify.com/GHSA-6q48-6c7w-9gw2/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-6q48-6c7w-9gw2

---
From sbomify Insights: https://insights.sbomify.com/GHSA-6q48-6c7w-9gw2/
Summaries are generated and may contain mistakes; the official description above is the record.
