{"answers":{"affected":"4 open source packages ship an affected version, including doctrine/orm.","exploited":"There is no known exploitation of GHSA-6q9v-4hq6-5m67 in the wild and no public exploit code.","fix":"Upgrade doctrine/orm to a fixed version for your release line: 1.2.4 or 2.0.3.","what":"GHSA-6q9v-4hq6-5m67 is a SQL injection vulnerability in doctrine/orm, published on 15 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-6q9v-4hq6-5m67 and fix it if it is affected.\n\nWhat it is: GHSA-6q9v-4hq6-5m67 is a SQL injection vulnerability in doctrine/orm, published on 15 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-6q9v-4hq6-5m67 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- doctrine/orm (Packagist): affected from 1.0.0; fixed in 1.2.4\n- doctrine/orm (Packagist): affected from 1.0.0; fixed in 1.2.4\n- doctrine/orm (Packagist): affected from 2.0.0; fixed in 2.0.3\n- doctrine/orm (Packagist): affected from 2.0.0; fixed in 2.0.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-6q9v-4hq6-5m67/ (Markdown: https://insights.sbomify.com/GHSA-6q9v-4hq6-5m67/index.md)","id":"GHSA-6q9v-4hq6-5m67","markdown":"https://insights.sbomify.com/GHSA-6q9v-4hq6-5m67/index.md","name":"GHSA-6q9v-4hq6-5m67","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP ORM library","requires_auth":"none","summary":"Doctrine library allows SQL injection via uncast limit/offset parameters, enabling attackers to read or modify database contents.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Doctrine is prone to SQL injection vulnerability. Users of Doctrine 1.2 and 2 should update to the newly released versions of both libraries immediately. Both versions only include the security fix and no other changes to their previous versions 1.2.3 and 2.0.2.\n\nAffected versions are:\n- 1.2.3 and earlier for PostgreSQL and DB2 Dialects\n- 2.0.2 and earlier\n\nThe security issue was found to affect the `Doctrine\\DBAL\\Platforms\\AbstractPlatform::modifyLimitQuery()` function which does not cast input values for limit and offset to integer and allows malicious SQL to be executed if these parameters are passed into Doctrine 2 directly from request variables without previous cast to integer. Functionality building on top using limit queries in the ORM such as `Doctrine\\ORM\\Query::setFirstResult()` and `Doctrine\\ORM\\Query::setMaxResults()` are also affected by this security issue.\n\nThe fix for this security issue breaks backwards compatibility for developers that extend the `Doctrine\\DBAL\\Platforms\\AbstractPlatform::modifyLimitQuery()` method, because it is now marked as final. Please overwrite the `Doctrine\\DBAL\\Platforms\\AbstractPlatform::doModifyLimitQuery()` method instead.","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Doctrine SQL injection vulnerability","id":"GHSA-6q9v-4hq6-5m67","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"sql_injection","year":"2024"},"n_packages":4,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["1.2.4"],"introduced":["1.0.0"],"last_affected":[],"package":"doctrine/orm","purl":null,"source":"GHSA-6q9v-4hq6-5m67"},{"ecosystem":"Packagist","fixed":["1.2.4"],"introduced":["1.0.0"],"last_affected":[],"package":"doctrine/orm","purl":"pkg:composer/doctrine/orm","source":"GHSA-6q9v-4hq6-5m67"},{"ecosystem":"Packagist","fixed":["2.0.3"],"introduced":["2.0.0"],"last_affected":[],"package":"doctrine/orm","purl":null,"source":"GHSA-6q9v-4hq6-5m67"},{"ecosystem":"Packagist","fixed":["2.0.3"],"introduced":["2.0.0"],"last_affected":[],"package":"doctrine/orm","purl":"pkg:composer/doctrine/orm","source":"GHSA-6q9v-4hq6-5m67"}],"products":null,"published":"2024-05-15","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Doctrine library allows SQL injection via uncast limit/offset parameters, enabling attackers to read or modify database contents.","url":"https://insights.sbomify.com/GHSA-6q9v-4hq6-5m67/"}