# GHSA-6r78-m64m-qwcf: Moq v4.20.0-rc to 4.20.1 share hashed user data

> Moq library versions leaked hashed user email addresses to remote servers during build time without user consent or disable option.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Aug 2023

## What is GHSA-6r78-m64m-qwcf?

GHSA-6r78-m64m-qwcf is a vulnerability in moq, published on 10 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Moq v4.20.0-rc to 4.20.1 include support for [SponsorLink](https://github.com/devlooped/SponsorLink), which runs an obfuscated DLL at build time that scans local `git config` data and shares the user's hashed email address with SponsorLink's remote servers. There is no option to disable this.

Moq v4.20.2 has removed this functionality.

## Which versions are affected by GHSA-6r78-m64m-qwcf?

2 open source packages ship an affected version, including moq.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moq` | NuGet | From 4.20.0-rc | 4.20.2 |
| `moq` | NuGet | From 4.20.0-rc | 4.20.2 |

## How do I fix GHSA-6r78-m64m-qwcf?

Upgrade moq to 4.20.2 or later.

## Is GHSA-6r78-m64m-qwcf being exploited?

There is no known exploitation of GHSA-6r78-m64m-qwcf in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-6r78-m64m-qwcf and fix it if it is affected.

What it is: GHSA-6r78-m64m-qwcf is a vulnerability in moq, published on 10 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-6r78-m64m-qwcf in the wild and no public exploit code.

Affected packages and fixed versions:
- moq (NuGet): affected from 4.20.0-rc; fixed in 4.20.2
- moq (NuGet): affected from 4.20.0-rc; fixed in 4.20.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-6r78-m64m-qwcf/ (Markdown: https://insights.sbomify.com/GHSA-6r78-m64m-qwcf/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-6r78-m64m-qwcf

---
From sbomify Insights: https://insights.sbomify.com/GHSA-6r78-m64m-qwcf/
Summaries are generated and may contain mistakes; the official description above is the record.
