GHSA-6v6p-g8cg-2hgg Improper Certificate Validation in node-sass affects eZ Platform

Not scored Published

Attackers can bypass certificate validation during binary downloads in node-sass, potentially enabling man-in-the-middle attacks against eZ Platform installations.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is GHSA-6v6p-g8cg-2hgg?

GHSA-6v6p-g8cg-2hgg is a vulnerability in ezsystems/ezplatform-admin-ui, published on 1 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Certificate validation in node-sass 2.0.0 to 4.14.1 is disabled when requesting binaries even if the user is not specifying an alternative download path. This affects eZ Platform v2.5 only. The maintainers resolved it by replacing node-sass 4.11 with sass 1.32.13. This issue also affects ezsystems/ezplatform and ezsystems/ezplatform-page-builder.

Which versions are affected by GHSA-6v6p-g8cg-2hgg?

2 open source packages ship an affected version, including ezsystems/ezplatform-admin-ui.

PackageAffectedFixed in
ezsystems/ezplatform-admin-ui PackagistFrom 1.5.01.5.27
ezsystems/ezplatform-admin-ui PackagistFrom 1.5.01.5.27

How do I fix GHSA-6v6p-g8cg-2hgg?

Upgrade ezsystems/ezplatform-admin-ui to 1.5.27 or later.

Is GHSA-6v6p-g8cg-2hgg being exploited?

There is no known exploitation of GHSA-6v6p-g8cg-2hgg in the wild and no public exploit code.

Sources

Is GHSA-6v6p-g8cg-2hgg in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free