{"answers":{"affected":"2 open source packages ship an affected version, including ezsystems/ezplatform-admin-ui.","exploited":"There is no known exploitation of GHSA-6v6p-g8cg-2hgg in the wild and no public exploit code.","fix":"Upgrade ezsystems/ezplatform-admin-ui to 1.5.27 or later.","what":"GHSA-6v6p-g8cg-2hgg is a vulnerability in ezsystems/ezplatform-admin-ui, published on 1 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-6v6p-g8cg-2hgg and fix it if it is affected.\n\nWhat it is: GHSA-6v6p-g8cg-2hgg is a vulnerability in ezsystems/ezplatform-admin-ui, published on 1 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-6v6p-g8cg-2hgg in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ezsystems/ezplatform-admin-ui (Packagist): affected from 1.5.0; fixed in 1.5.27\n- ezsystems/ezplatform-admin-ui (Packagist): affected from 1.5.0; fixed in 1.5.27\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-6v6p-g8cg-2hgg/ (Markdown: https://insights.sbomify.com/GHSA-6v6p-g8cg-2hgg/index.md)","id":"GHSA-6v6p-g8cg-2hgg","markdown":"https://insights.sbomify.com/GHSA-6v6p-g8cg-2hgg/index.md","name":"GHSA-6v6p-g8cg-2hgg","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js Sass library","requires_auth":"none","summary":"Attackers can bypass certificate validation during binary downloads in node-sass, potentially enabling man-in-the-middle attacks against eZ Platform installations.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Certificate validation in node-sass 2.0.0 to 4.14.1 is disabled when requesting binaries even if the user is not specifying an alternative download path. This affects eZ Platform v2.5 only. The maintainers resolved it by replacing node-sass 4.11 with sass 1.32.13. This issue also affects ezsystems/ezplatform and ezsystems/ezplatform-page-builder.","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Improper Certificate Validation in node-sass affects eZ Platform","id":"GHSA-6v6p-g8cg-2hgg","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"security_feature_bypass","year":"2022"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["1.5.27"],"introduced":["1.5.0"],"last_affected":[],"package":"ezsystems/ezplatform-admin-ui","purl":null,"source":"GHSA-6v6p-g8cg-2hgg"},{"ecosystem":"Packagist","fixed":["1.5.27"],"introduced":["1.5.0"],"last_affected":[],"package":"ezsystems/ezplatform-admin-ui","purl":"pkg:composer/ezsystems/ezplatform-admin-ui","source":"GHSA-6v6p-g8cg-2hgg"}],"products":null,"published":"2022-04-01","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can bypass certificate validation during binary downloads in node-sass, potentially enabling man-in-the-middle attacks against eZ Platform installations.","url":"https://insights.sbomify.com/GHSA-6v6p-g8cg-2hgg/"}