# GHSA-6v6p-g8cg-2hgg: Improper Certificate Validation in node-sass affects eZ Platform

> Attackers can bypass certificate validation during binary downloads in node-sass, potentially enabling man-in-the-middle attacks against eZ Platform installations.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Apr 2022

## What is GHSA-6v6p-g8cg-2hgg?

GHSA-6v6p-g8cg-2hgg is a vulnerability in ezsystems/ezplatform-admin-ui, published on 1 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Certificate validation in node-sass 2.0.0 to 4.14.1 is disabled when requesting binaries even if the user is not specifying an alternative download path. This affects eZ Platform v2.5 only. The maintainers resolved it by replacing node-sass 4.11 with sass 1.32.13. This issue also affects ezsystems/ezplatform and ezsystems/ezplatform-page-builder.

## Which versions are affected by GHSA-6v6p-g8cg-2hgg?

2 open source packages ship an affected version, including ezsystems/ezplatform-admin-ui.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ezsystems/ezplatform-admin-ui` | Packagist | From 1.5.0 | 1.5.27 |
| `ezsystems/ezplatform-admin-ui` | Packagist | From 1.5.0 | 1.5.27 |

## How do I fix GHSA-6v6p-g8cg-2hgg?

Upgrade ezsystems/ezplatform-admin-ui to 1.5.27 or later.

## Is GHSA-6v6p-g8cg-2hgg being exploited?

There is no known exploitation of GHSA-6v6p-g8cg-2hgg in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-6v6p-g8cg-2hgg and fix it if it is affected.

What it is: GHSA-6v6p-g8cg-2hgg is a vulnerability in ezsystems/ezplatform-admin-ui, published on 1 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-6v6p-g8cg-2hgg in the wild and no public exploit code.

Affected packages and fixed versions:
- ezsystems/ezplatform-admin-ui (Packagist): affected from 1.5.0; fixed in 1.5.27
- ezsystems/ezplatform-admin-ui (Packagist): affected from 1.5.0; fixed in 1.5.27

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-6v6p-g8cg-2hgg/ (Markdown: https://insights.sbomify.com/GHSA-6v6p-g8cg-2hgg/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-6v6p-g8cg-2hgg

---
From sbomify Insights: https://insights.sbomify.com/GHSA-6v6p-g8cg-2hgg/
Summaries are generated and may contain mistakes; the official description above is the record.
