{"answers":{"affected":"3 open source packages ship an affected version, including gogs.io/gogs.","exploited":"There is no known exploitation of GHSA-6vxv-wg6j-5qwp in the wild and no public exploit code.","fix":"Upgrade gogs.io/gogs to 0.14.3 or later.","what":"GHSA-6vxv-wg6j-5qwp is a cross-site scripting vulnerability in gogs.io/gogs, published on 19 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-6vxv-wg6j-5qwp and fix it if it is affected.\n\nWhat it is: GHSA-6vxv-wg6j-5qwp is a cross-site scripting vulnerability in gogs.io/gogs, published on 19 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-6vxv-wg6j-5qwp in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- gogs.io/gogs (Go): affected all versions; no fix listed\n- gogs.io/gogs (Go): affected all versions; fixed in 0.14.3\n- gogs.io/gogs (Go): affected all versions; fixed in 0.14.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-6vxv-wg6j-5qwp/ (Markdown: https://insights.sbomify.com/GHSA-6vxv-wg6j-5qwp/index.md)","id":"GHSA-6vxv-wg6j-5qwp","markdown":"https://insights.sbomify.com/GHSA-6vxv-wg6j-5qwp/index.md","name":"GHSA-6vxv-wg6j-5qwp","record":{"aliases":["GO-2026-5193"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Gogs Git server","requires_auth":"low_privilege","summary":"An attacker with repository creation rights can inject XSS payloads into Jupyter notebooks, potentially taking over victim accounts.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Summary\n\nGogs renders Jupyter notebook files (`.ipynb`) using [jsvine/notebookjs](https://github.com/jsvine/notebookjs), but the version is outdated, missing patches for known XSS vulnerabilities.\n\n### Details\n\nGogs uses version 0.4.2 of notebookjs to render Jupyter notebook files:\n\nhttps://github.com/gogs/gogs/blob/7297aee50d4c115836c7de8a3a233daaef87b911/templates/base/head.tmpl#L47\n\nThe latest version of [jsvine/notebookjs](https://github.com/jsvine/notebookjs) is 0.8.3, patching many XSS vulnerabilities in its releases. The proof of concept below shows an example working payload that renders HTML through Markdown.\n\n### PoC\n\n1. Create a new repository\n2. Create a file inside the repository named `xss.ipynb` and give it the following content:\n\n```json\n{\"cells\": [{\"cell_type\": \"markdown\", \"metadata\": {}, \"source\": [\"\u003cimg src=x onerror=\\\"alert(origin)\\\"\u003e\"]}], \"metadata\": {}, \"nbformat\": 4, \"nbformat_minor\": 2}\n```\n\n\u003cimg width=\"1054\" height=\"208\" alt=\"image\" src=\"https://github.com/user-attachments/assets/49b7f33c-c4df-4537-99e9-b1ea74f2c6de\" /\u003e\n\n3. Save the file and view the file in Gogs. Notice that the XSS popup triggers:\n\n\u003cimg width=\"1317\" height=\"407\" alt=\"image\" src=\"https://github.com/user-attachments/assets/3b18d870-7194-41b0-92db-687e952abc07\" /\u003e\n\n### Impact\n\nAny user with rights to create repositories can create XSS payloads that take over the victim's account when visited. Either through their own exploration of the files or by directly linking them the vulnerable URL.","ecosystems":["Go"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Gogs: XSS in .ipynb files renderer due to outdated notebookjs","id":"GHSA-6vxv-wg6j-5qwp","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Go","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":3,"n_references":null,"packages":[{"ecosystem":"Go","fixed":[],"introduced":["0"],"last_affected":[],"package":"gogs.io/gogs","purl":"pkg:golang/gogs.io/gogs","source":"GO-2026-5193"},{"ecosystem":"Go","fixed":["0.14.3"],"introduced":["0"],"last_affected":[],"package":"gogs.io/gogs","purl":null,"source":"GHSA-6vxv-wg6j-5qwp"},{"ecosystem":"Go","fixed":["0.14.3"],"introduced":["0"],"last_affected":[],"package":"gogs.io/gogs","purl":"pkg:golang/gogs.io/gogs","source":"GHSA-6vxv-wg6j-5qwp"}],"products":null,"published":"2026-06-19","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An attacker with repository creation rights can inject XSS payloads into Jupyter notebooks, potentially taking over victim accounts.","url":"https://insights.sbomify.com/GHSA-6vxv-wg6j-5qwp/"}