GHSA-6wm4-3rjj-c8xx Magento Security enhancements that help close RCE,XSS,CSRF and other vulnerabilities
Not scored
Published
Check this codebase for GHSA-6wm4-3rjj-c8xx and fix it if it is affected.
What it is: GHSA-6wm4-3rjj-c8xx is a vulnerability in magento/community-edition, published on 15 May 2024. It can be exploited over the network.
Exploitation: There is no known exploitation of GHSA-6wm4-3rjj-c8xx in the wild and no public exploit code.
Affected packages and fixed versions:
- magento/community-edition (Packagist): affected from 1.5.0.0; fixed in 1.9.4.0
- magento/community-edition (Packagist): affected from 1.5.0.0; fixed in 1.9.4.0
Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.
Reference: https://insights.sbomify.com/GHSA-6wm4-3rjj-c8xx/ (Markdown: https://insights.sbomify.com/GHSA-6wm4-3rjj-c8xx/index.md)
Security patch for Magento addresses multiple vulnerabilities including RCE, XSS, and CSRF, requiring an upgrade to secure the e-commerce platform.
- Exploited in the wild
- Not known
- Login needed
- Not stated
- Attackable
- Over the internet
- Victim action needed
- Not stated
- Fix
- Available
What is GHSA-6wm4-3rjj-c8xx?
GHSA-6wm4-3rjj-c8xx is a vulnerability in magento/community-edition, published on 15 May 2024. It can be exploited over the network.
Official description
SUPEE-10975, Magento Commerce 1.14.4.0 and Open Source 1.9.4.0 contain multiple security enhancements that help close remote code execution (RCE), cross-site scripting (XSS), cross-site request forgery (CSRF) and other vulnerabilities.
Which versions are affected by GHSA-6wm4-3rjj-c8xx?
2 open source packages ship an affected version, including magento/community-edition.
| Package | Affected | Fixed in |
|---|---|---|
magento/community-edition Packagist | From 1.5.0.0 | 1.9.4.0 |
magento/community-edition Packagist | From 1.5.0.0 | 1.9.4.0 |
How do I fix GHSA-6wm4-3rjj-c8xx?
Upgrade magento/community-edition to 1.9.4.0 or later.
Is GHSA-6wm4-3rjj-c8xx being exploited?
There is no known exploitation of GHSA-6wm4-3rjj-c8xx in the wild and no public exploit code.