{"answers":{"affected":"2 open source packages ship an affected version, including magento/community-edition.","exploited":"There is no known exploitation of GHSA-6wm4-3rjj-c8xx in the wild and no public exploit code.","fix":"Upgrade magento/community-edition to 1.9.4.0 or later.","what":"GHSA-6wm4-3rjj-c8xx is a vulnerability in magento/community-edition, published on 15 May 2024. It can be exploited over the network."},"fix_prompt":"Check this codebase for GHSA-6wm4-3rjj-c8xx and fix it if it is affected.\n\nWhat it is: GHSA-6wm4-3rjj-c8xx is a vulnerability in magento/community-edition, published on 15 May 2024. It can be exploited over the network.\nExploitation: There is no known exploitation of GHSA-6wm4-3rjj-c8xx in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- magento/community-edition (Packagist): affected from 1.5.0.0; fixed in 1.9.4.0\n- magento/community-edition (Packagist): affected from 1.5.0.0; fixed in 1.9.4.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-6wm4-3rjj-c8xx/ (Markdown: https://insights.sbomify.com/GHSA-6wm4-3rjj-c8xx/index.md)","id":"GHSA-6wm4-3rjj-c8xx","markdown":"https://insights.sbomify.com/GHSA-6wm4-3rjj-c8xx/index.md","name":"GHSA-6wm4-3rjj-c8xx","record":{"aliases":[],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Magento e-commerce platform","requires_auth":"unknown","summary":"Security patch for Magento addresses multiple vulnerabilities including RCE, XSS, and CSRF, requiring an upgrade to secure the e-commerce platform.","user_interaction":"unknown","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"SUPEE-10975, Magento Commerce 1.14.4.0 and Open Source 1.9.4.0 contain multiple security enhancements that help close remote code execution (RCE), cross-site scripting (XSS), cross-site request forgery (CSRF) and other vulnerabilities.","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Magento Security enhancements that help close RCE,XSS,CSRF and other vulnerabilities","id":"GHSA-6wm4-3rjj-c8xx","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"other","year":"2024"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["1.9.4.0"],"introduced":["1.5.0.0"],"last_affected":[],"package":"magento/community-edition","purl":null,"source":"GHSA-6wm4-3rjj-c8xx"},{"ecosystem":"Packagist","fixed":["1.9.4.0"],"introduced":["1.5.0.0"],"last_affected":[],"package":"magento/community-edition","purl":"pkg:composer/magento/community-edition","source":"GHSA-6wm4-3rjj-c8xx"}],"products":null,"published":"2024-05-15","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Security patch for Magento addresses multiple vulnerabilities including RCE, XSS, and CSRF, requiring an upgrade to secure the e-commerce platform.","url":"https://insights.sbomify.com/GHSA-6wm4-3rjj-c8xx/"}