{"answers":{"affected":"2 open source packages ship an affected version, including meraki.","exploited":"There is no known exploitation of GHSA-6x4h-9622-fqr6 in the wild and no public exploit code.","fix":"Upgrade meraki to 1.40.1 or later.","what":"GHSA-6x4h-9622-fqr6 is a vulnerability in meraki, published on 13 Dec 2023."},"fix_prompt":"Check this codebase for GHSA-6x4h-9622-fqr6 and fix it if it is affected.\n\nWhat it is: GHSA-6x4h-9622-fqr6 is a vulnerability in meraki, published on 13 Dec 2023. \nExploitation: There is no known exploitation of GHSA-6x4h-9622-fqr6 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- meraki (PyPI): affected all versions; fixed in 1.40.1\n- meraki (PyPI): affected all versions; fixed in 1.40.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-6x4h-9622-fqr6/ (Markdown: https://insights.sbomify.com/GHSA-6x4h-9622-fqr6/index.md)","id":"GHSA-6x4h-9622-fqr6","markdown":"https://insights.sbomify.com/GHSA-6x4h-9622-fqr6/index.md","name":"GHSA-6x4h-9622-fqr6","record":{"aliases":[],"analysis":null,"analysis_generated_by":null,"assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"aiohttp is an asynchronous HTTP client/server framework for asyncio and Python. Improper validation made it possible for an attacker to modify the HTTP request (e.g. to insert a new header) or create a new HTTP request if the attacker controls the HTTP version. The vulnerability only occurs if the attacker can control the HTTP version of the request. This issue has been patched in version 3.9.0.\n\nmeraki from version 1.40.1 requires aiohttp 3.9.0","ecosystems":["PyPI"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Improper validation in meraki","id":"GHSA-6x4h-9622-fqr6","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"PyPI","product":null,"products":[],"type":null,"year":"2023"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"PyPI","fixed":["1.40.1"],"introduced":["0"],"last_affected":[],"package":"meraki","purl":null,"source":"GHSA-6x4h-9622-fqr6"},{"ecosystem":"PyPI","fixed":["1.40.1"],"introduced":["0"],"last_affected":[],"package":"meraki","purl":"pkg:pypi/meraki","source":"GHSA-6x4h-9622-fqr6"}],"products":null,"published":"2023-12-13","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":null,"url":"https://insights.sbomify.com/GHSA-6x4h-9622-fqr6/"}