{"answers":{"affected":"4 open source packages ship an affected version, including loopback.","exploited":"There is no known exploitation of GHSA-724c-6vrf-99rq in the wild and no public exploit code.","fix":"Upgrade loopback to a fixed version for your release line: 2.42.0 or 3.26.0.","what":"GHSA-724c-6vrf-99rq is a vulnerability in loopback, published on 2 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-724c-6vrf-99rq and fix it if it is affected.\n\nWhat it is: GHSA-724c-6vrf-99rq is a vulnerability in loopback, published on 2 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-724c-6vrf-99rq in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- loopback (npm): affected all versions; fixed in 2.42.0\n- loopback (npm): affected all versions; fixed in 2.42.0\n- loopback (npm): affected from 3.0.0; fixed in 3.26.0\n- loopback (npm): affected from 3.0.0; fixed in 3.26.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-724c-6vrf-99rq/ (Markdown: https://insights.sbomify.com/GHSA-724c-6vrf-99rq/index.md)","id":"GHSA-724c-6vrf-99rq","markdown":"https://insights.sbomify.com/GHSA-724c-6vrf-99rq/index.md","name":"GHSA-724c-6vrf-99rq","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js web framework","requires_auth":"none","summary":"Attackers can retrieve sensitive user data from the login endpoint via invalid requests, potentially aiding credential theft.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Versions of `loopback` prior to 3.26.0 (3.x) and 2.42.0 (2.x) are vulnerable to Sensitive Data Exposure. Invalid API requests to the login endpoint may return information about the first user in the database. This can be used alongside other attacks for credential theft.\n\n## Recommendation\n\nIf you're using `loopback` 3.x upgrade to version 3.26.0 or later.\nIf you're using `loopback` 2.x upgrade to version 2.42.0 or later.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Sensitive Data Exposure in loopback","id":"GHSA-724c-6vrf-99rq","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"information_disclosure","year":"2020"},"n_packages":4,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["2.42.0"],"introduced":["0"],"last_affected":[],"package":"loopback","purl":null,"source":"GHSA-724c-6vrf-99rq"},{"ecosystem":"npm","fixed":["2.42.0"],"introduced":["0"],"last_affected":[],"package":"loopback","purl":"pkg:npm/loopback","source":"GHSA-724c-6vrf-99rq"},{"ecosystem":"npm","fixed":["3.26.0"],"introduced":["3.0.0"],"last_affected":[],"package":"loopback","purl":null,"source":"GHSA-724c-6vrf-99rq"},{"ecosystem":"npm","fixed":["3.26.0"],"introduced":["3.0.0"],"last_affected":[],"package":"loopback","purl":"pkg:npm/loopback","source":"GHSA-724c-6vrf-99rq"}],"products":null,"published":"2020-09-02","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can retrieve sensitive user data from the login endpoint via invalid requests, potentially aiding credential theft.","url":"https://insights.sbomify.com/GHSA-724c-6vrf-99rq/"}