# GHSA-724c-6vrf-99rq: Sensitive Data Exposure in loopback

> Attackers can retrieve sensitive user data from the login endpoint via invalid requests, potentially aiding credential theft.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Sep 2020

## What is GHSA-724c-6vrf-99rq?

GHSA-724c-6vrf-99rq is a vulnerability in loopback, published on 2 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Versions of `loopback` prior to 3.26.0 (3.x) and 2.42.0 (2.x) are vulnerable to Sensitive Data Exposure. Invalid API requests to the login endpoint may return information about the first user in the database. This can be used alongside other attacks for credential theft.

## Recommendation

If you're using `loopback` 3.x upgrade to version 3.26.0 or later.
If you're using `loopback` 2.x upgrade to version 2.42.0 or later.

## Which versions are affected by GHSA-724c-6vrf-99rq?

4 open source packages ship an affected version, including loopback.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `loopback` | npm | All versions | 2.42.0 |
| `loopback` | npm | All versions | 2.42.0 |
| `loopback` | npm | From 3.0.0 | 3.26.0 |
| `loopback` | npm | From 3.0.0 | 3.26.0 |

## How do I fix GHSA-724c-6vrf-99rq?

Upgrade loopback to a fixed version for your release line: 2.42.0 or 3.26.0.

## Is GHSA-724c-6vrf-99rq being exploited?

There is no known exploitation of GHSA-724c-6vrf-99rq in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-724c-6vrf-99rq and fix it if it is affected.

What it is: GHSA-724c-6vrf-99rq is a vulnerability in loopback, published on 2 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-724c-6vrf-99rq in the wild and no public exploit code.

Affected packages and fixed versions:
- loopback (npm): affected all versions; fixed in 2.42.0
- loopback (npm): affected all versions; fixed in 2.42.0
- loopback (npm): affected from 3.0.0; fixed in 3.26.0
- loopback (npm): affected from 3.0.0; fixed in 3.26.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-724c-6vrf-99rq/ (Markdown: https://insights.sbomify.com/GHSA-724c-6vrf-99rq/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-724c-6vrf-99rq

---
From sbomify Insights: https://insights.sbomify.com/GHSA-724c-6vrf-99rq/
Summaries are generated and may contain mistakes; the official description above is the record.
