{"answers":{"affected":"2 open source packages ship an affected version, including shopware/shopware.","exploited":"There is no known exploitation of GHSA-7336-ghhp-f2qj in the wild and no public exploit code.","fix":"Upgrade shopware/shopware to 5.2.16 or later.","what":"GHSA-7336-ghhp-f2qj is a code injection vulnerability in shopware/shopware, published on 21 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-7336-ghhp-f2qj and fix it if it is affected.\n\nWhat it is: GHSA-7336-ghhp-f2qj is a code injection vulnerability in shopware/shopware, published on 21 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-7336-ghhp-f2qj in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- shopware/shopware (Packagist): affected from 5.2.15; fixed in 5.2.16\n- shopware/shopware (Packagist): affected from 5.2.15; fixed in 5.2.16\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-7336-ghhp-f2qj/ (Markdown: https://insights.sbomify.com/GHSA-7336-ghhp-f2qj/index.md)","id":"GHSA-7336-ghhp-f2qj","markdown":"https://insights.sbomify.com/GHSA-7336-ghhp-f2qj/index.md","name":"GHSA-7336-ghhp-f2qj","record":{"aliases":[],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Shopware e-commerce platform","requires_auth":"none","summary":"Attackers can execute arbitrary code in Shopware if custom templates improperly handle field data, requiring a patch to secure the application.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Under certain circumstances, it’s possible to execute an unauthorized foreign code in Shopware in versions prior to 5.2.16. One possible threat is if a template that doesn’t derive from the Shopware standard has been completely copied. Themes or plugins that execute or overwrite the following template code are vulnerable.\n\n- Affected file: emotion.tpl\n\nPath template file \"Emotion template\": templates / _default / frontend / forms / elements.tpl\nPath template file \"Responsive template\": themes/Frontend/Bare/frontend/forms/elements.tpl\n\nThe complete line beginning with: `{eval var=$sSupport.sFields[$sKey]...` should be exchanged with the following:\n\n```\n{$sSupport.sFields[$sKey]|replace:'{literal}':''|replace:'{/literal}':''|replace:'%*%':\"{s name='RequiredField' namespace='frontend/register/index'}{/s}\"}\n```","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Shopware Remote Code Execution Vulnerability","id":"GHSA-7336-ghhp-f2qj","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"code_injection","year":"2024"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["5.2.16"],"introduced":["5.2.15"],"last_affected":[],"package":"shopware/shopware","purl":null,"source":"GHSA-7336-ghhp-f2qj"},{"ecosystem":"Packagist","fixed":["5.2.16"],"introduced":["5.2.15"],"last_affected":[],"package":"shopware/shopware","purl":"pkg:composer/shopware/shopware","source":"GHSA-7336-ghhp-f2qj"}],"products":null,"published":"2024-05-21","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can execute arbitrary code in Shopware if custom templates improperly handle field data, requiring a patch to secure the application.","url":"https://insights.sbomify.com/GHSA-7336-ghhp-f2qj/"}