{"answers":{"affected":"4 open source packages ship an affected version, including decompress-zip.","exploited":"There is no known exploitation of GHSA-73v8-v6g4-vrpm in the wild and no public exploit code.","fix":"Upgrade decompress-zip to a fixed version for your release line: 0.2.2 or 0.3.2.","what":"GHSA-73v8-v6g4-vrpm is a path traversal vulnerability in decompress-zip, published on 2 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-73v8-v6g4-vrpm and fix it if it is affected.\n\nWhat it is: GHSA-73v8-v6g4-vrpm is a path traversal vulnerability in decompress-zip, published on 2 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-73v8-v6g4-vrpm in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- decompress-zip (npm): affected all versions; fixed in 0.2.2\n- decompress-zip (npm): affected all versions; fixed in 0.2.2\n- decompress-zip (npm): affected from 0.3.0; fixed in 0.3.2\n- decompress-zip (npm): affected from 0.3.0; fixed in 0.3.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-73v8-v6g4-vrpm/ (Markdown: https://insights.sbomify.com/GHSA-73v8-v6g4-vrpm/index.md)","id":"GHSA-73v8-v6g4-vrpm","markdown":"https://insights.sbomify.com/GHSA-73v8-v6g4-vrpm/index.md","name":"GHSA-73v8-v6g4-vrpm","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js zip library","requires_auth":"none","summary":"Attackers can overwrite arbitrary files via Zip-Slip in decompress-zip, requiring an upgrade to secure the library.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Vulnerable versions of `decompress-zip` are affected by the Zip-Slip vulnerability, an arbitrary file write vulnerability. The vulnerability occurs because `decompress-zip` does not verify that extracted files do not resolve to targets outside of the extraction root directory.\n\n## Recommendation\n\nFor `decompress-zip` 0.2.x upgrade to 0.2.2 or later.\nFor `decompress-zip` 0.3.x upgrade to 0.3.2 or later.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Arbitrary File Overwrite in decompress-zip","id":"GHSA-73v8-v6g4-vrpm","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"path_traversal","year":"2020"},"n_packages":4,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["0.2.2"],"introduced":["0"],"last_affected":[],"package":"decompress-zip","purl":null,"source":"GHSA-73v8-v6g4-vrpm"},{"ecosystem":"npm","fixed":["0.2.2"],"introduced":["0"],"last_affected":[],"package":"decompress-zip","purl":"pkg:npm/decompress-zip","source":"GHSA-73v8-v6g4-vrpm"},{"ecosystem":"npm","fixed":["0.3.2"],"introduced":["0.3.0"],"last_affected":[],"package":"decompress-zip","purl":null,"source":"GHSA-73v8-v6g4-vrpm"},{"ecosystem":"npm","fixed":["0.3.2"],"introduced":["0.3.0"],"last_affected":[],"package":"decompress-zip","purl":"pkg:npm/decompress-zip","source":"GHSA-73v8-v6g4-vrpm"}],"products":null,"published":"2020-09-02","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can overwrite arbitrary files via Zip-Slip in decompress-zip, requiring an upgrade to secure the library.","url":"https://insights.sbomify.com/GHSA-73v8-v6g4-vrpm/"}