# GHSA-73v8-v6g4-vrpm: Arbitrary File Overwrite in decompress-zip

> Attackers can overwrite arbitrary files via Zip-Slip in decompress-zip, requiring an upgrade to secure the library.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Sep 2020

## What is GHSA-73v8-v6g4-vrpm?

GHSA-73v8-v6g4-vrpm is a path traversal vulnerability in decompress-zip, published on 2 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Vulnerable versions of `decompress-zip` are affected by the Zip-Slip vulnerability, an arbitrary file write vulnerability. The vulnerability occurs because `decompress-zip` does not verify that extracted files do not resolve to targets outside of the extraction root directory.

## Recommendation

For `decompress-zip` 0.2.x upgrade to 0.2.2 or later.
For `decompress-zip` 0.3.x upgrade to 0.3.2 or later.

## Which versions are affected by GHSA-73v8-v6g4-vrpm?

4 open source packages ship an affected version, including decompress-zip.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `decompress-zip` | npm | All versions | 0.2.2 |
| `decompress-zip` | npm | All versions | 0.2.2 |
| `decompress-zip` | npm | From 0.3.0 | 0.3.2 |
| `decompress-zip` | npm | From 0.3.0 | 0.3.2 |

## How do I fix GHSA-73v8-v6g4-vrpm?

Upgrade decompress-zip to a fixed version for your release line: 0.2.2 or 0.3.2.

## Is GHSA-73v8-v6g4-vrpm being exploited?

There is no known exploitation of GHSA-73v8-v6g4-vrpm in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-73v8-v6g4-vrpm and fix it if it is affected.

What it is: GHSA-73v8-v6g4-vrpm is a path traversal vulnerability in decompress-zip, published on 2 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-73v8-v6g4-vrpm in the wild and no public exploit code.

Affected packages and fixed versions:
- decompress-zip (npm): affected all versions; fixed in 0.2.2
- decompress-zip (npm): affected all versions; fixed in 0.2.2
- decompress-zip (npm): affected from 0.3.0; fixed in 0.3.2
- decompress-zip (npm): affected from 0.3.0; fixed in 0.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-73v8-v6g4-vrpm/ (Markdown: https://insights.sbomify.com/GHSA-73v8-v6g4-vrpm/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-73v8-v6g4-vrpm

---
From sbomify Insights: https://insights.sbomify.com/GHSA-73v8-v6g4-vrpm/
Summaries are generated and may contain mistakes; the official description above is the record.
