{"answers":{"affected":"2 open source packages ship an affected version, including awscli.","exploited":"There is no known exploitation of GHSA-747p-wmpv-9c78 in the wild and no public exploit code.","fix":"Upgrade awscli to 1.44.38 or later.","what":"GHSA-747p-wmpv-9c78 is a vulnerability in awscli, published on 27 Feb 2026. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-747p-wmpv-9c78 and fix it if it is affected.\n\nWhat it is: GHSA-747p-wmpv-9c78 is a vulnerability in awscli, published on 27 Feb 2026. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-747p-wmpv-9c78 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- awscli (PyPI): affected from 1.13.0; fixed in 1.44.38\n- awscli (PyPI): affected from 1.13.0; fixed in 1.44.38\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-747p-wmpv-9c78/ (Markdown: https://insights.sbomify.com/GHSA-747p-wmpv-9c78/index.md)","id":"GHSA-747p-wmpv-9c78","markdown":"https://insights.sbomify.com/GHSA-747p-wmpv-9c78/index.md","name":"GHSA-747p-wmpv-9c78","record":{"aliases":[],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"AWS CLI","requires_auth":"none","summary":"Local attackers can read sensitive AWS command history if the optional cli_history feature is enabled on multi-user Unix systems.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"**Summary**\nAWS CLI is a command line tool for interacting with AWS services. When the cli_history feature is enabled, the history database file is created with default permissions, potentially allowing other local users on a multi-user system to read the file.\n\n**Impact**\nWhen cli_history is enabled, AWS CLI stores command history including command parameters and API request/response data in a local SQLite database. On multi-user Unix systems, the default file permissions may allow other local users to read this file, potentially exposing sensitive information. This issue only affects users who have explicitly enabled cli_history, which is disabled by default.\n\n**Impacted versions:** 1.13.0 - 1.44.37 (v1), 2.0.0 - 2.33.20 (v2)\n\n**Patches**\nThis issue has been addressed in the latest versions 2.33.21 and 1.44.38 of AWS CLI. We recommend upgrading to the latest version and ensuring any forked or derivative code is patched to incorporate the new fixes. \n\n**Workarounds**\nUsers can manually set restrictive permissions on the history database file. Alternatively, disable cli_history by removing `cli_history = enabled` from the AWS config file.\n\n**Resources**\nIf there are any questions or comments about this advisory, contact AWS Security via the [vulnerability reporting page](https://aws.amazon.com/security/vulnerability-reporting) or directly via email to [aws-security@amazon.com](mailto:aws-security@amazon.com). Please do not create a public GitHub issue.","ecosystems":["PyPI"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"AWS CLI: cli_history database does not restrict file permissions on Unix systems","id":"GHSA-747p-wmpv-9c78","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"information_disclosure","year":"2026"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"PyPI","fixed":["1.44.38"],"introduced":["1.13.0"],"last_affected":[],"package":"awscli","purl":null,"source":"GHSA-747p-wmpv-9c78"},{"ecosystem":"PyPI","fixed":["1.44.38"],"introduced":["1.13.0"],"last_affected":[],"package":"awscli","purl":"pkg:pypi/awscli","source":"GHSA-747p-wmpv-9c78"}],"products":null,"published":"2026-02-27","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Local attackers can read sensitive AWS command history if the optional cli_history feature is enabled on multi-user Unix systems.","url":"https://insights.sbomify.com/GHSA-747p-wmpv-9c78/"}