{"answers":{"affected":"2 open source packages ship an affected version, including pgp.","exploited":"There is no known exploitation of GHSA-7587-4wv6-m68m in the wild and no public exploit code.","fix":"Upgrade pgp to 0.19.0 or later.","what":"GHSA-7587-4wv6-m68m is a denial of service vulnerability in pgp, published on 13 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-7587-4wv6-m68m and fix it if it is affected.\n\nWhat it is: GHSA-7587-4wv6-m68m is a denial of service vulnerability in pgp, published on 13 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-7587-4wv6-m68m in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pgp (crates.io): affected from 0.16.0-alpha.0; fixed in 0.19.0\n- pgp (crates.io): affected from 0.16.0-alpha.0; fixed in 0.19.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-7587-4wv6-m68m/ (Markdown: https://insights.sbomify.com/GHSA-7587-4wv6-m68m/index.md)","id":"GHSA-7587-4wv6-m68m","markdown":"https://insights.sbomify.com/GHSA-7587-4wv6-m68m/index.md","name":"GHSA-7587-4wv6-m68m","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Rust PGP library","requires_auth":"none","summary":"Attackers can crash applications using rPGP by sending crafted RSA secret key packets, causing a denial of service.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Summary\nIt was possible to trigger an unhandled edge case in the Rust Crypto rsa crate through rPGP packet parsing functionality, and crash the process that runs rPGP. This problem has been patched in a new rsa version. The new release of rPGP ensures a patched version of the rsa crate is in use, which prevents this issue.\n\n### Details\nWhile parsing a special RSA secret key packet, rPGP calls the rsa crate with the provided key. On vulnerable versions, this results in a Rust \"panic\" during key construction. Note that an attacker can trigger this situation even in places where applications don't expect to handle foreign key material, for example while attempting to receive a message.\n\nFor more information on the rsa crate vulnerability, see https://github.com/RustCrypto/RSA/security/advisories/GHSA-9c48-w39g-hm26 and https://github.com/RustCrypto/RSA/pull/624.\nIn rPGP, this has been fixed via https://github.com/rpgp/rpgp/pull/698.\n\n### Impact\nThis issue impacts availability (i.e. applications can crash).\n\nAffected rPGP versions: rPGP 0.16.0-alpha.0 to 0.18.0\nVulnerable rsa versions: all before version 0.9.10\n\n### Workaround\nThe issue depends on the combination of affected rPGP and rsa versions. Users of affected rPGP versions can pin the patched rsa 0.9.10 via a cargo lockfile to mitigate the issue.\n\n### Attribution\nDiscovered by Christian Reitter from Radically Open Security during a security review for Proton AG.","ecosystems":["crates.io"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"rPGP vulnerable to parser crash on crafted RSA secret key packets through CVE-2026-21895","id":"GHSA-7587-4wv6-m68m","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"crates.io","fixed":["0.19.0"],"introduced":["0.16.0-alpha.0"],"last_affected":[],"package":"pgp","purl":null,"source":"GHSA-7587-4wv6-m68m"},{"ecosystem":"crates.io","fixed":["0.19.0"],"introduced":["0.16.0-alpha.0"],"last_affected":[],"package":"pgp","purl":"pkg:cargo/pgp","source":"GHSA-7587-4wv6-m68m"}],"products":null,"published":"2026-02-13","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can crash applications using rPGP by sending crafted RSA secret key packets, causing a denial of service.","url":"https://insights.sbomify.com/GHSA-7587-4wv6-m68m/"}