# GHSA-7587-4wv6-m68m: rPGP vulnerable to parser crash on crafted RSA secret key packets through CVE-2026-21895

> Attackers can crash applications using rPGP by sending crafted RSA secret key packets, causing a denial of service.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Feb 2026

## What is GHSA-7587-4wv6-m68m?

GHSA-7587-4wv6-m68m is a denial of service vulnerability in pgp, published on 13 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

### Summary
It was possible to trigger an unhandled edge case in the Rust Crypto rsa crate through rPGP packet parsing functionality, and crash the process that runs rPGP. This problem has been patched in a new rsa version. The new release of rPGP ensures a patched version of the rsa crate is in use, which prevents this issue.

### Details
While parsing a special RSA secret key packet, rPGP calls the rsa crate with the provided key. On vulnerable versions, this results in a Rust "panic" during key construction. Note that an attacker can trigger this situation even in places where applications don't expect to handle foreign key material, for example while attempting to receive a message.

For more information on the rsa crate vulnerability, see https://github.com/RustCrypto/RSA/security/advisories/GHSA-9c48-w39g-hm26 and https://github.com/RustCrypto/RSA/pull/624.
In rPGP, this has been fixed via https://github.com/rpgp/rpgp/pull/698.

### Impact
This issue impacts availability (i.e. applications can crash).

Affected rPGP versions: rPGP 0.16.0-alpha.0 to 0.18.0
Vulnerable rsa versions: all before version 0.9.10

### Workaround
The issue depends on the combination of affected rPGP and rsa versions. Users of affected rPGP versions can pin the patched rsa 0.9.10 via a cargo lockfile to mitigate the issue.

### Attribution
Discovered by Christian Reitter from Radically Open Security during a security review for Proton AG.

## Which versions are affected by GHSA-7587-4wv6-m68m?

2 open source packages ship an affected version, including pgp.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pgp` | crates.io | From 0.16.0-alpha.0 | 0.19.0 |
| `pgp` | crates.io | From 0.16.0-alpha.0 | 0.19.0 |

## How do I fix GHSA-7587-4wv6-m68m?

Upgrade pgp to 0.19.0 or later.

## Is GHSA-7587-4wv6-m68m being exploited?

There is no known exploitation of GHSA-7587-4wv6-m68m in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-7587-4wv6-m68m and fix it if it is affected.

What it is: GHSA-7587-4wv6-m68m is a denial of service vulnerability in pgp, published on 13 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-7587-4wv6-m68m in the wild and no public exploit code.

Affected packages and fixed versions:
- pgp (crates.io): affected from 0.16.0-alpha.0; fixed in 0.19.0
- pgp (crates.io): affected from 0.16.0-alpha.0; fixed in 0.19.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-7587-4wv6-m68m/ (Markdown: https://insights.sbomify.com/GHSA-7587-4wv6-m68m/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-7587-4wv6-m68m

---
From sbomify Insights: https://insights.sbomify.com/GHSA-7587-4wv6-m68m/
Summaries are generated and may contain mistakes; the official description above is the record.
