{"answers":{"affected":"2 open source packages ship an affected version, including com.vaadin:vaadin-bom.","exploited":"There is no known exploitation of GHSA-76f4-fw33-6j2v in the wild and no public exploit code.","fix":"Upgrade com.vaadin:vaadin-bom to 15.0.5 or later.","what":"GHSA-76f4-fw33-6j2v is a vulnerability in com.vaadin:vaadin-bom, published on 19 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-76f4-fw33-6j2v and fix it if it is affected.\n\nWhat it is: GHSA-76f4-fw33-6j2v is a vulnerability in com.vaadin:vaadin-bom, published on 19 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-76f4-fw33-6j2v in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- com.vaadin:vaadin-bom (Maven): affected from 15.0.0; fixed in 15.0.5\n- com.vaadin:vaadin-bom (Maven): affected from 15.0.0; fixed in 15.0.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-76f4-fw33-6j2v/ (Markdown: https://insights.sbomify.com/GHSA-76f4-fw33-6j2v/index.md)","id":"GHSA-76f4-fw33-6j2v","markdown":"https://insights.sbomify.com/GHSA-76f4-fw33-6j2v/index.md","name":"GHSA-76f4-fw33-6j2v","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"Vaadin Java library","requires_auth":"none","summary":"Insecure default configuration in Vaadin flow-server may expose sensitive data to attackers when used with REST controllers.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Insecure configuration of default `ObjectMapper` in `com.vaadin:flow-server` versions 3.0.0 through 3.0.5 (Vaadin 15.0.0 through 15.0.4) may expose sensitive data if the application also uses e.g. `@RestController`\n\n- https://vaadin.com/security/cve-2020-36319","ecosystems":["Maven"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Potential sensitive data exposure in applications using Vaadin 15","id":"GHSA-76f4-fw33-6j2v","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Maven","product":null,"products":[],"type":"information_disclosure","year":"2021"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Maven","fixed":["15.0.5"],"introduced":["15.0.0"],"last_affected":[],"package":"com.vaadin:vaadin-bom","purl":null,"source":"GHSA-76f4-fw33-6j2v"},{"ecosystem":"Maven","fixed":["15.0.5"],"introduced":["15.0.0"],"last_affected":[],"package":"com.vaadin:vaadin-bom","purl":"pkg:maven/com.vaadin/vaadin-bom","source":"GHSA-76f4-fw33-6j2v"}],"products":null,"published":"2021-04-19","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Insecure default configuration in Vaadin flow-server may expose sensitive data to attackers when used with REST controllers.","url":"https://insights.sbomify.com/GHSA-76f4-fw33-6j2v/"}