{"answers":{"affected":"2 open source packages ship an affected version, including pimcore/pimcore.","exploited":"There is no known exploitation of GHSA-76r7-h46w-463r in the wild and no public exploit code.","fix":"Upgrade pimcore/pimcore to 10.5.17 or later.","what":"GHSA-76r7-h46w-463r is a cross-site scripting vulnerability in pimcore/pimcore, published on 15 Feb 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-76r7-h46w-463r and fix it if it is affected.\n\nWhat it is: GHSA-76r7-h46w-463r is a cross-site scripting vulnerability in pimcore/pimcore, published on 15 Feb 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-76r7-h46w-463r in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pimcore/pimcore (Packagist): affected all versions; fixed in 10.5.17\n- pimcore/pimcore (Packagist): affected all versions; fixed in 10.5.17\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-76r7-h46w-463r/ (Markdown: https://insights.sbomify.com/GHSA-76r7-h46w-463r/index.md)","id":"GHSA-76r7-h46w-463r","markdown":"https://insights.sbomify.com/GHSA-76r7-h46w-463r/index.md","name":"GHSA-76r7-h46w-463r","record":{"aliases":[],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["other"],"network_reachable":"yes","non_default_config":false,"product_category":"Pimcore CMS","requires_auth":"low_privilege","summary":"An attacker can inject malicious scripts via XSS in Pimcore, potentially compromising user sessions or data.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\nAn attacker can use XSS to send a malicious script to an unsuspecting user.\n\n### Patches\nUpdate to version 10.5.17 or apply this patch manually https://github.com/pimcore/pimcore/pull/14301.patch\n\n### Workarounds\nApply https://github.com/pimcore/pimcore/pull/14301.patch manually.\n\n### References\nhttps://huntr.dev/bounties/75bc7d07-46a7-4ed9-a405-af4fc47fb422/","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Cross Site Scripting (XSS) in Model\\DataObject\\Data\\UrlSlug","id":"GHSA-76r7-h46w-463r","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2023"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["10.5.17"],"introduced":["0"],"last_affected":[],"package":"pimcore/pimcore","purl":null,"source":"GHSA-76r7-h46w-463r"},{"ecosystem":"Packagist","fixed":["10.5.17"],"introduced":["0"],"last_affected":[],"package":"pimcore/pimcore","purl":"pkg:composer/pimcore/pimcore","source":"GHSA-76r7-h46w-463r"}],"products":null,"published":"2023-02-15","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An attacker can inject malicious scripts via XSS in Pimcore, potentially compromising user sessions or data.","url":"https://insights.sbomify.com/GHSA-76r7-h46w-463r/"}