{"answers":{"affected":"2 open source packages ship an affected version, including 3f/pygmentize.","exploited":"There is no known exploitation of GHSA-77mv-mp2j-gxxh in the wild and no public exploit code.","fix":"Upgrade 3f/pygmentize to 1.2 or later.","what":"GHSA-77mv-mp2j-gxxh is a code injection vulnerability in 3f/pygmentize, published on 15 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-77mv-mp2j-gxxh and fix it if it is affected.\n\nWhat it is: GHSA-77mv-mp2j-gxxh is a code injection vulnerability in 3f/pygmentize, published on 15 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-77mv-mp2j-gxxh in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- 3f/pygmentize (Packagist): affected all versions; fixed in 1.2\n- 3f/pygmentize (Packagist): affected all versions; fixed in 1.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-77mv-mp2j-gxxh/ (Markdown: https://insights.sbomify.com/GHSA-77mv-mp2j-gxxh/index.md)","id":"GHSA-77mv-mp2j-gxxh","markdown":"https://insights.sbomify.com/GHSA-77mv-mp2j-gxxh/index.md","name":"GHSA-77mv-mp2j-gxxh","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Python syntax highlighter","requires_auth":"none","summary":"Attackers can execute arbitrary code by exploiting unsafe input sanitization in the pygmentize highlight function.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"pygmentize is prone to remote code execution due to an unsafe sanitazation of user input when passed to the `highlight` function.","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"pygmentize Remote Code Execution","id":"GHSA-77mv-mp2j-gxxh","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"code_injection","year":"2024"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["1.2"],"introduced":["0"],"last_affected":[],"package":"3f/pygmentize","purl":null,"source":"GHSA-77mv-mp2j-gxxh"},{"ecosystem":"Packagist","fixed":["1.2"],"introduced":["0"],"last_affected":[],"package":"3f/pygmentize","purl":"pkg:composer/3f/pygmentize","source":"GHSA-77mv-mp2j-gxxh"}],"products":null,"published":"2024-05-15","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can execute arbitrary code by exploiting unsafe input sanitization in the pygmentize highlight function.","url":"https://insights.sbomify.com/GHSA-77mv-mp2j-gxxh/"}