{"answers":{"affected":"2 open source packages ship an affected version, including fomantic-ui.","exploited":"There is no known exploitation of GHSA-788m-pj96-7w2c in the wild and no public exploit code.","fix":"Upgrade fomantic-ui to 2.7.0 or later.","what":"GHSA-788m-pj96-7w2c is a cross-site scripting vulnerability in fomantic-ui, published on 2 Sep 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-788m-pj96-7w2c and fix it if it is affected.\n\nWhat it is: GHSA-788m-pj96-7w2c is a cross-site scripting vulnerability in fomantic-ui, published on 2 Sep 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-788m-pj96-7w2c in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- fomantic-ui (npm): affected all versions; fixed in 2.7.0\n- fomantic-ui (npm): affected all versions; fixed in 2.7.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-788m-pj96-7w2c/ (Markdown: https://insights.sbomify.com/GHSA-788m-pj96-7w2c/index.md)","id":"GHSA-788m-pj96-7w2c","markdown":"https://insights.sbomify.com/GHSA-788m-pj96-7w2c/index.md","name":"GHSA-788m-pj96-7w2c","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"UI component library","requires_auth":"none","summary":"Attackers can execute arbitrary scripts in victim browsers via unencoded input in fomantic-ui dropdowns, requiring user interaction.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Versions of `fomantic-ui` are vulnerable to Cross-Site Scripting. Lack of output encoding on the selection dropdowns can lead to user input being executed instead of printed as text.\n\n## Recommendation\n\nUpgrade to version 2.7.0 or later.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Cross-Site Scripting in fomantic-ui","id":"GHSA-788m-pj96-7w2c","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2020"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["2.7.0"],"introduced":["0"],"last_affected":[],"package":"fomantic-ui","purl":null,"source":"GHSA-788m-pj96-7w2c"},{"ecosystem":"npm","fixed":["2.7.0"],"introduced":["0"],"last_affected":[],"package":"fomantic-ui","purl":"pkg:npm/fomantic-ui","source":"GHSA-788m-pj96-7w2c"}],"products":null,"published":"2020-09-02","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can execute arbitrary scripts in victim browsers via unencoded input in fomantic-ui dropdowns, requiring user interaction.","url":"https://insights.sbomify.com/GHSA-788m-pj96-7w2c/"}