{"answers":{"affected":"2 open source packages ship an affected version, including openclaw.","exploited":"There is no known exploitation of GHSA-796m-2973-wc5q in the wild and no public exploit code.","fix":"Upgrade openclaw to 2026.2.23 or later.","what":"GHSA-796m-2973-wc5q is a vulnerability in openclaw, published on 3 Mar 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-796m-2973-wc5q and fix it if it is affected.\n\nWhat it is: GHSA-796m-2973-wc5q is a vulnerability in openclaw, published on 3 Mar 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-796m-2973-wc5q in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- openclaw (npm): affected all versions; fixed in 2026.2.23\n- openclaw (npm): affected all versions; fixed in 2026.2.23\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-796m-2973-wc5q/ (Markdown: https://insights.sbomify.com/GHSA-796m-2973-wc5q/index.md)","id":"GHSA-796m-2973-wc5q","markdown":"https://insights.sbomify.com/GHSA-796m-2973-wc5q/index.md","name":"GHSA-796m-2973-wc5q","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"OpenClaw npm library","requires_auth":"low_privilege","summary":"Attackers can bypass exec allowlists via env wrapper mismatches to execute arbitrary commands, requiring an upgrade to the patched version.","user_interaction":"required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Summary\n`tools.exec` allowlist/safe-bins evaluation could diverge from runtime execution for wrapper commands using GNU `env -S/--split-string` semantics. This allowed policy checks to treat a command as a benign safe-bin invocation while runtime executed a different payload.\n\n### Affected Packages / Versions\n- Package: `openclaw` (npm)\n- Vulnerable versions: `\u003c= 2026.2.22-2` (latest currently published npm version)\n- Patched version (released): `2026.2.23`\n\n### Impact\nAn attacker able to influence tool command text (for example via untrusted prompt/content injection reaching an exec-capable flow) could bypass allowlist/safe-bins intent and execute unexpected commands.\n\n### Technical Details\nRoot cause was policy/runtime interpretation mismatch for dispatch wrappers:\n- analysis resolved an effective executable from wrapper-unwrapped argv,\n- execution could still run original wrapper argv semantics,\n- safe-bin short-flag handling also allowed unknown short options in clusters.\n\n### Remediation\nThe fix hardens exec approvals to fail closed and enforce analysis/runtime parity:\n- introduce wrapper execution planning with semantic-wrapper blocking,\n- carry planned `effectiveArgv` + `policyBlocked` metadata through resolution,\n- evaluate allowlist/safe-bins against planned argv,\n- enforce canonical rebuilt shell command from planned argv for allowlist auto-paths,\n- use planned argv for node-host/mac exec-host invocation paths,\n- reject unknown short safe-bin flags,\n- add regression tests for semantic `env` wrappers and parity fixtures.\n\n### Fix Commit(s)\n- `a1c4bf07c6baad3ef87a0e710fe9aef127b1f606`\n\n### Release Process Note\n`patched_versions` is pre-set to the released version (`2026.2.23`). Patched in `2026.2.23` and published.\n\nOpenClaw thanks @jiseoung for reporting.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"OpenClaw has exec allowlist/safeBins policy-runtime mismatch via env -S wrapper interpretation","id":"GHSA-796m-2973-wc5q","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"security_feature_bypass","year":"2026"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["2026.2.23"],"introduced":["0"],"last_affected":[],"package":"openclaw","purl":null,"source":"GHSA-796m-2973-wc5q"},{"ecosystem":"npm","fixed":["2026.2.23"],"introduced":["0"],"last_affected":[],"package":"openclaw","purl":"pkg:npm/openclaw","source":"GHSA-796m-2973-wc5q"}],"products":null,"published":"2026-03-03","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can bypass exec allowlists via env wrapper mismatches to execute arbitrary commands, requiring an upgrade to the patched version.","url":"https://insights.sbomify.com/GHSA-796m-2973-wc5q/"}