# GHSA-79xg-q4qm-7v9w: CWA-2025-006: wasmd's improper error handling may lead to IBC channel opening despite error

> Improper error handling allows IBC channels to open despite contract errors, bypassing intended security checks in CosmWasm nodes.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Jun 2025
- **Also known as:** GO-2025-3755

## What is GHSA-79xg-q4qm-7v9w?

GHSA-79xg-q4qm-7v9w is a vulnerability in github.com/CosmWasm/wasmd, published on 11 Jun 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

# CWA-2025-006: Improper error handling may lead to IBC channel opening despite error

**Severity**

High (Considerable + Likely)[^1]

**Affected versions:**

- wasmd 0.60.0
- wasmd >= 0.51.0 < 0.55.1

**Patched versions:**

- wasmd 0.60.1, 0.55.1, 0.54.1, 0.53.3

## Description of the bug

A contract erroring during IBC channel opening does not prevent the channel from opening.

## Applying the patch

The patch will be shipped in a wasmd release. You will also have to update `libwasmvm` if you build statically.
If you already use the latest / close to latest wasmd, you can update more or less as follows:

1. Check the current wasmd version: `go list -m github.com/CosmWasm/wasmd`
2. Bump the `github.com/CosmWasm/wasmd` dependency in your go.mod to 0.60.1 (Cosmos SDK 0.53 compatible), 0.55.1 (Cosmos SDK 0.50 compatible), 0.54.1 or 0.53.3; `go mod tidy`; commit.
3. If you use the static libraries `libwasmvm_muslc.aarch64.a`/`libwasmvm_muslc.x86_64.a`, make sure that you use the same version as your wasmvm version.
4. Check the updated wasmd version: `go list -m github.com/CosmWasm/wasmd` and ensure you see 0.60.1, 0.55.1, 0.54.1 or 0.53.3.
5. Follow your regular practices to deploy chain upgrades.

The patch is consensus breaking.

## Acknowledgement

This problem was discovered during an audit of the CosmWasm stack performed by Sherlock and funded by ICF/ICL in Q1 2025. Thank you for that work!

If you believe you have found a bug in the Interchain Stack or would like to contribute to the
program by reporting a bug, please see <https://hackerone.com/cosmos>.

## Timeline

- 2025-03-03: Auditor informs Confio about this issue.
- 2025-04-10: Confio developed the patch internally.
- 2025-06-05: Upcoming patch is announced.
- 2025-06-10: Patch is released.

[^1]: following Amulet's Severity Classification Framework ACMv1.2: <https://github.com/interchainio/security/blob/0295254e8645301ccb606d46108a45cede0a73e0/resources/CLASSIFICATION_MATRIX.md>

## Which versions are affected by GHSA-79xg-q4qm-7v9w?

9 open source packages ship an affected version, including github.com/CosmWasm/wasmd.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/CosmWasm/wasmd` | Go | From 0.51.0 | 0.53.3, 0.54.1, 0.55.1, 0.60.1 |
| `github.com/CosmWasm/wasmd` | Go | From 0.51.0 | 0.53.3 |
| `github.com/CosmWasm/wasmd` | Go | From 0.51.0 | 0.53.3 |
| `github.com/CosmWasm/wasmd` | Go | From 0.54.0 | 0.54.1 |
| `github.com/CosmWasm/wasmd` | Go | From 0.54.0 | 0.54.1 |
| `github.com/CosmWasm/wasmd` | Go | From 0.55.0 | 0.55.1 |
| `github.com/CosmWasm/wasmd` | Go | From 0.55.0 | 0.55.1 |
| `github.com/CosmWasm/wasmd` | Go | From 0.60.0 | 0.60.1 |
| `github.com/CosmWasm/wasmd` | Go | From 0.60.0 | 0.60.1 |

## How do I fix GHSA-79xg-q4qm-7v9w?

Upgrade github.com/CosmWasm/wasmd to a fixed version for your release line: 0.53.3, 0.54.1, 0.55.1 or 0.60.1.

## Is GHSA-79xg-q4qm-7v9w being exploited?

There is no known exploitation of GHSA-79xg-q4qm-7v9w in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-79xg-q4qm-7v9w and fix it if it is affected.

What it is: GHSA-79xg-q4qm-7v9w is a vulnerability in github.com/CosmWasm/wasmd, published on 11 Jun 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-79xg-q4qm-7v9w in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/CosmWasm/wasmd (Go): affected from 0.51.0; fixed in 0.53.3, 0.54.1, 0.55.1, 0.60.1
- github.com/CosmWasm/wasmd (Go): affected from 0.51.0; fixed in 0.53.3
- github.com/CosmWasm/wasmd (Go): affected from 0.51.0; fixed in 0.53.3
- github.com/CosmWasm/wasmd (Go): affected from 0.54.0; fixed in 0.54.1
- github.com/CosmWasm/wasmd (Go): affected from 0.54.0; fixed in 0.54.1
- github.com/CosmWasm/wasmd (Go): affected from 0.55.0; fixed in 0.55.1
- github.com/CosmWasm/wasmd (Go): affected from 0.55.0; fixed in 0.55.1
- github.com/CosmWasm/wasmd (Go): affected from 0.60.0; fixed in 0.60.1
- github.com/CosmWasm/wasmd (Go): affected from 0.60.0; fixed in 0.60.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-79xg-q4qm-7v9w/ (Markdown: https://insights.sbomify.com/GHSA-79xg-q4qm-7v9w/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-79xg-q4qm-7v9w

---
From sbomify Insights: https://insights.sbomify.com/GHSA-79xg-q4qm-7v9w/
Summaries are generated and may contain mistakes; the official description above is the record.
