{"answers":{"affected":"2 open source packages ship an affected version, including laravel/socialite.","exploited":"There is no known exploitation of GHSA-7fjv-25q9-2w88 in the wild and no public exploit code.","fix":"Upgrade laravel/socialite to 2.0.10 or later.","what":"GHSA-7fjv-25q9-2w88 is an authentication bypass vulnerability in laravel/socialite, published on 15 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-7fjv-25q9-2w88 and fix it if it is affected.\n\nWhat it is: GHSA-7fjv-25q9-2w88 is an authentication bypass vulnerability in laravel/socialite, published on 15 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-7fjv-25q9-2w88 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- laravel/socialite (Packagist): affected from 1.0.0; fixed in 2.0.10\n- laravel/socialite (Packagist): affected from 1.0.0; fixed in 2.0.10\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-7fjv-25q9-2w88/ (Markdown: https://insights.sbomify.com/GHSA-7fjv-25q9-2w88/index.md)","id":"GHSA-7fjv-25q9-2w88","markdown":"https://insights.sbomify.com/GHSA-7fjv-25q9-2w88/index.md","name":"GHSA-7fjv-25q9-2w88","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Laravel OAuth library","requires_auth":"none","summary":"Attackers can guess OAuth state values to hijack user sessions in the Laravel Socialite library, requiring an upgrade to secure authentication.","user_interaction":"required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"laravel/socialite versions prior to 2.0.10 are susceptible to a security vulnerability related to state guessing during OAuth authentication. This vulnerability could potentially lead to session hijacking, allowing attackers to compromise user sessions. The issue has been addressed and fixed in version 2.0.10.","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"State Guessing Vulnerability in laravel/socialite","id":"GHSA-7fjv-25q9-2w88","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"auth_bypass","year":"2024"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["2.0.10"],"introduced":["1.0.0"],"last_affected":[],"package":"laravel/socialite","purl":null,"source":"GHSA-7fjv-25q9-2w88"},{"ecosystem":"Packagist","fixed":["2.0.10"],"introduced":["1.0.0"],"last_affected":[],"package":"laravel/socialite","purl":"pkg:composer/laravel/socialite","source":"GHSA-7fjv-25q9-2w88"}],"products":null,"published":"2024-05-15","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can guess OAuth state values to hijack user sessions in the Laravel Socialite library, requiring an upgrade to secure authentication.","url":"https://insights.sbomify.com/GHSA-7fjv-25q9-2w88/"}