{"answers":{"affected":"2 open source packages ship an affected version, including matrix-synapse.","exploited":"There is no known exploitation of GHSA-7h5v-85w9-pq6c in the wild and no public exploit code.","fix":"Upgrade matrix-synapse to 1.33.0 or later.","what":"GHSA-7h5v-85w9-pq6c is a denial of service vulnerability in matrix-synapse, published on 19 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-7h5v-85w9-pq6c and fix it if it is affected.\n\nWhat it is: GHSA-7h5v-85w9-pq6c is a denial of service vulnerability in matrix-synapse, published on 19 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-7h5v-85w9-pq6c in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- matrix-synapse (PyPI): affected all versions; fixed in 1.33.0\n- matrix-synapse (PyPI): affected all versions; fixed in 1.33.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-7h5v-85w9-pq6c/ (Markdown: https://insights.sbomify.com/GHSA-7h5v-85w9-pq6c/index.md)","id":"GHSA-7h5v-85w9-pq6c","markdown":"https://insights.sbomify.com/GHSA-7h5v-85w9-pq6c/index.md","name":"GHSA-7h5v-85w9-pq6c","record":{"aliases":[],"analysis":{"component_type":"server_software","fix_type":"patch","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Matrix homeserver","requires_auth":"none","summary":"Attackers can cause denial of service via resource exhaustion by sending unvalidated input to third-party identifier endpoints in Synapse.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\nMissing input validation of some parameters on the endpoints used to confirm third-party identifiers could cause excessive use of disk space and memory leading to resource exhaustion.\n\n### Patches\nThe issue is fixed by https://github.com/matrix-org/synapse/pull/9855.\n\n### Workarounds\nThere are no known workarounds.\n\n### References\nn/a\n\n### For more information\nIf you have any questions or comments about this advisory, email us at security@matrix.org.","ecosystems":["PyPI"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Denial of service (via resource exhaustion) due to improper input validation in third-party identifier endpoint","id":"GHSA-7h5v-85w9-pq6c","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"denial_of_service","year":"2021"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"PyPI","fixed":["1.33.0"],"introduced":["0"],"last_affected":[],"package":"matrix-synapse","purl":null,"source":"GHSA-7h5v-85w9-pq6c"},{"ecosystem":"PyPI","fixed":["1.33.0"],"introduced":["0"],"last_affected":[],"package":"matrix-synapse","purl":"pkg:pypi/matrix-synapse","source":"GHSA-7h5v-85w9-pq6c"}],"products":null,"published":"2021-05-19","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can cause denial of service via resource exhaustion by sending unvalidated input to third-party identifier endpoints in Synapse.","url":"https://insights.sbomify.com/GHSA-7h5v-85w9-pq6c/"}