{"answers":{"affected":"2 open source packages ship an affected version, including auth0/login.","exploited":"There is no known exploitation of GHSA-7hh9-gp72-wh7h in the wild and no public exploit code.","fix":"Upgrade auth0/login to 7.20.0 or later.","what":"GHSA-7hh9-gp72-wh7h is an authentication bypass vulnerability in auth0/login, published on 17 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-7hh9-gp72-wh7h and fix it if it is affected.\n\nWhat it is: GHSA-7hh9-gp72-wh7h is an authentication bypass vulnerability in auth0/login, published on 17 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-7hh9-gp72-wh7h in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- auth0/login (Packagist): affected from 7.0.0; fixed in 7.20.0\n- auth0/login (Packagist): affected from 7.0.0; fixed in 7.20.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-7hh9-gp72-wh7h/ (Markdown: https://insights.sbomify.com/GHSA-7hh9-gp72-wh7h/index.md)","id":"GHSA-7hh9-gp72-wh7h","markdown":"https://insights.sbomify.com/GHSA-7hh9-gp72-wh7h/index.md","name":"GHSA-7hh9-gp72-wh7h","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Auth0 Laravel SDK","requires_auth":"none","summary":"Attackers can bypass audience validation to use ID tokens as Access tokens, potentially gaining unauthorized access to protected resources.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Description\nIn applications built with the Auth0-PHP SDK, the audience validation in access tokens is performed improperly. Without proper validation, affected applications may accept ID tokens as Access tokens.\n\n### Affected product and versions\nUsers are affected if they meet the following preconditions:\n\n- Applications using the Auth0 laravel-auth0 SDK with versions between 7.0.0 and 7.19.0,\n- Auth0 laravel-auth0 SDK uses the Auth0-PHP SDK with versions between 8.0.0 and 8.17.0.\n\n### Resolution\nUpgrade Auth0/laravel-auth0 to version 7.20.0 or greater.\n\n### Acknowledgement\nOkta would like to thank Jafar Sadiq (iaf4r) for their discovery and responsible disclosure.","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Auth0 Laravel SDK has Improper Audience Validation via Auth0-PHP SDK dependency","id":"GHSA-7hh9-gp72-wh7h","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"auth_bypass","year":"2025"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["7.20.0"],"introduced":["7.0.0"],"last_affected":[],"package":"auth0/login","purl":null,"source":"GHSA-7hh9-gp72-wh7h"},{"ecosystem":"Packagist","fixed":["7.20.0"],"introduced":["7.0.0"],"last_affected":[],"package":"auth0/login","purl":"pkg:composer/auth0/login","source":"GHSA-7hh9-gp72-wh7h"}],"products":null,"published":"2025-12-17","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can bypass audience validation to use ID tokens as Access tokens, potentially gaining unauthorized access to protected resources.","url":"https://insights.sbomify.com/GHSA-7hh9-gp72-wh7h/"}