# GHSA-7j52-6fjp-58gr: Inconsistent storage layout for ERC2771ContextUpgradeable


- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 14 Mar 2022

## What is GHSA-7j52-6fjp-58gr?

GHSA-7j52-6fjp-58gr is a vulnerability in @openzeppelin/contracts-upgradeable, published on 14 Mar 2022. 

### Official description

### Impact

The storage layout of the ERC2771ContextUpgradeable is not constant between versions. 
- versions `4.0.0`, `4.1.0` and `4.2.0`, the contract has a length of 51 slots. 
- since `4.3.0`, the contract has a length of 50 slots
- future versions will continue using 50 slots. 

This difference in layout could result in breaking upgrades if someone upgrades from an affected version to a non-affected version. It is thus recommended to be extremely careful when upgrading from a contract that uses ERC2771ContextUpgradeable `<4.3.0` to a newer version that uses `>=4.3.0`.

We've assessed the instances of this contract found on chain (with publicly verified source code) and notified the corresponding teams of the risk that an upgrade could cause.

### Workarounds

Potentially breaking upgrades would be caught by the OpenZeppelin Upgrades Plugins for Hardhat and Truffle. It is recommended to use this tooling for all your upgrades.

If you need to upgrade to a newer version of the Upgradeable Contracts library, we recommend copying the previous implementation ERC2771ContextUpgradeable (available in the `release-4.2` branch) and packaging it with your code.

### Reference

https://github.com/OpenZeppelin/openzeppelin-transpiler/pull/86

### For more information

If you have any questions, comments, or need assistance regarding this advisory, email us at [security@openzeppelin.com](mailto:security@openzeppelin.com).

To submit security reports please use [our bug bounty on Immunefi](https://immunefi.com/bounty/openzeppelin/).

## Which versions are affected by GHSA-7j52-6fjp-58gr?

2 open source packages ship an affected version, including @openzeppelin/contracts-upgradeable.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@openzeppelin/contracts-upgradeable` | npm | From 4.0.0 | 4.3.0 |
| `@openzeppelin/contracts-upgradeable` | npm | From 4.0.0 | 4.3.0 |

## How do I fix GHSA-7j52-6fjp-58gr?

Upgrade @openzeppelin/contracts-upgradeable to 4.3.0 or later.

## Is GHSA-7j52-6fjp-58gr being exploited?

There is no known exploitation of GHSA-7j52-6fjp-58gr in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-7j52-6fjp-58gr and fix it if it is affected.

What it is: GHSA-7j52-6fjp-58gr is a vulnerability in @openzeppelin/contracts-upgradeable, published on 14 Mar 2022. 
Exploitation: There is no known exploitation of GHSA-7j52-6fjp-58gr in the wild and no public exploit code.

Affected packages and fixed versions:
- @openzeppelin/contracts-upgradeable (npm): affected from 4.0.0; fixed in 4.3.0
- @openzeppelin/contracts-upgradeable (npm): affected from 4.0.0; fixed in 4.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-7j52-6fjp-58gr/ (Markdown: https://insights.sbomify.com/GHSA-7j52-6fjp-58gr/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-7j52-6fjp-58gr

---
From sbomify Insights: https://insights.sbomify.com/GHSA-7j52-6fjp-58gr/
Summaries are generated and may contain mistakes; the official description above is the record.
