{"answers":{"affected":"4 open source packages ship an affected version, including public.","exploited":"There is no known exploitation of GHSA-7jfh-2xc9-ccv7 in the wild and no public exploit code.","fix":"Upgrade public to 0.1.4 or later.","what":"GHSA-7jfh-2xc9-ccv7 is a cross-site scripting vulnerability in public, published on 31 May 2019. It can be exploited over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-7jfh-2xc9-ccv7 and fix it if it is affected.\n\nWhat it is: GHSA-7jfh-2xc9-ccv7 is a cross-site scripting vulnerability in public, published on 31 May 2019. It can be exploited over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-7jfh-2xc9-ccv7 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- public (npm): affected all versions; no fix listed\n- public (npm): affected all versions; no fix listed\n- public (npm): affected all versions; fixed in 0.1.4\n- public (npm): affected all versions; fixed in 0.1.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-7jfh-2xc9-ccv7/ (Markdown: https://insights.sbomify.com/GHSA-7jfh-2xc9-ccv7/index.md)","id":"GHSA-7jfh-2xc9-ccv7","markdown":"https://insights.sbomify.com/GHSA-7jfh-2xc9-ccv7/index.md","name":"GHSA-7jfh-2xc9-ccv7","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"no_fix_stated","impacts":["other"],"network_reachable":"yes","non_default_config":false,"product_category":"npm public module","requires_auth":"unknown","summary":"Stored cross-site scripting vulnerability in the public npm module allows attackers to inject malicious scripts, with no current fix available.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"All versions of `public` are vulnerable to stored cross-site scripting (XSS). \n\n## Recommendation\n\nNo fix is currently available for this vulnerability. It is our recommendation to not install or use this module at this time.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Cross-Site Scripting in public","id":"GHSA-7jfh-2xc9-ccv7","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2019"},"n_packages":4,"n_references":null,"packages":[{"ecosystem":"npm","fixed":[],"introduced":[],"last_affected":[],"package":"public","purl":null,"source":"GHSA-7jfh-2xc9-ccv7"},{"ecosystem":"npm","fixed":[],"introduced":[],"last_affected":[],"package":"public","purl":"pkg:npm/public","source":"GHSA-7jfh-2xc9-ccv7"},{"ecosystem":"npm","fixed":["0.1.4"],"introduced":["0"],"last_affected":[],"package":"public","purl":null,"source":"GHSA-7jfh-2xc9-ccv7"},{"ecosystem":"npm","fixed":["0.1.4"],"introduced":["0"],"last_affected":[],"package":"public","purl":"pkg:npm/public","source":"GHSA-7jfh-2xc9-ccv7"}],"products":null,"published":"2019-05-31","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Stored cross-site scripting vulnerability in the public npm module allows attackers to inject malicious scripts, with no current fix available.","url":"https://insights.sbomify.com/GHSA-7jfh-2xc9-ccv7/"}