GHSA-7jp2-5h22-m432 Auth0 Symfony SDK Does Not Properly Handle File Types in Bulk User Import
The Auth0 Symfony SDK allows arbitrary file path access during bulk user imports, potentially exposing sensitive data or bypassing security controls.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is GHSA-7jp2-5h22-m432?
GHSA-7jp2-5h22-m432 is a path traversal vulnerability in auth0/symfony, published on 1 Oct 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Overview
In applications built with the Auth0-PHP SDK, the Bulk User Import endpoint does not validate the file path wrapper or value. Without proper validation, affected applications may accept arbitrary file paths or URLs.
Am I affected?
You are affected by this vulnerability if you meet the following preconditions:
- Applications using the Auth0 Symfony SDK with versions between 2.0.2 and 5.4.1,
- Auth0 Symfony SDK uses the Auth0-PHP SDK with versions between 3.3.0 and 8.16.0.
Fix
Upgrade Auth0/symfony to version 5.5.0 or greater.
Acknowledgement
Okta would like to thank Mohamed Amine Saidani (pwni) for discovering this vulnerability.
Which versions are affected by GHSA-7jp2-5h22-m432?
2 open source packages ship an affected version, including auth0/symfony.
| Package | Affected | Fixed in |
|---|---|---|
auth0/symfony Packagist | From 2.0.2 | 5.5.0 |
auth0/symfony Packagist | From 2.0.2 | 5.5.0 |
How do I fix GHSA-7jp2-5h22-m432?
Upgrade auth0/symfony to 5.5.0 or later.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is GHSA-7jp2-5h22-m432 being exploited?
There is no known exploitation of GHSA-7jp2-5h22-m432 in the wild and no public exploit code.