# GHSA-7jp2-5h22-m432: Auth0 Symfony SDK Does Not Properly Handle File Types in Bulk User Import

> The Auth0 Symfony SDK allows arbitrary file path access during bulk user imports, potentially exposing sensitive data or bypassing security controls.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Oct 2025

## What is GHSA-7jp2-5h22-m432?

GHSA-7jp2-5h22-m432 is a path traversal vulnerability in auth0/symfony, published on 1 Oct 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

### Overview
In applications built with the Auth0-PHP SDK, the Bulk User Import endpoint does not validate the file path wrapper or value. Without proper validation, affected applications may accept arbitrary file paths or URLs.

### Am I affected?
You are affected by this vulnerability if you meet the following preconditions:
1. Applications using the Auth0 Symfony SDK with versions between 2.0.2 and 5.4.1,
2. Auth0 Symfony SDK uses the Auth0-PHP SDK with versions between 3.3.0 and 8.16.0.

### Fix
Upgrade Auth0/symfony to version 5.5.0 or greater.

### Acknowledgement
Okta would like to thank Mohamed Amine Saidani (pwni) for discovering this vulnerability.

## Which versions are affected by GHSA-7jp2-5h22-m432?

2 open source packages ship an affected version, including auth0/symfony.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `auth0/symfony` | Packagist | From 2.0.2 | 5.5.0 |
| `auth0/symfony` | Packagist | From 2.0.2 | 5.5.0 |

## How do I fix GHSA-7jp2-5h22-m432?

Upgrade auth0/symfony to 5.5.0 or later.

## Is GHSA-7jp2-5h22-m432 being exploited?

There is no known exploitation of GHSA-7jp2-5h22-m432 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-7jp2-5h22-m432 and fix it if it is affected.

What it is: GHSA-7jp2-5h22-m432 is a path traversal vulnerability in auth0/symfony, published on 1 Oct 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-7jp2-5h22-m432 in the wild and no public exploit code.

Affected packages and fixed versions:
- auth0/symfony (Packagist): affected from 2.0.2; fixed in 5.5.0
- auth0/symfony (Packagist): affected from 2.0.2; fixed in 5.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-7jp2-5h22-m432/ (Markdown: https://insights.sbomify.com/GHSA-7jp2-5h22-m432/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-7jp2-5h22-m432

---
From sbomify Insights: https://insights.sbomify.com/GHSA-7jp2-5h22-m432/
Summaries are generated and may contain mistakes; the official description above is the record.
