# GHSA-7mpf-4465-7fc2: Winter: Stored XSS through Backend List widget image columns

> Stored XSS in Winter CMS backend allows attackers to execute scripts in admin sessions if a plugin uses image list columns with unescaped URLs.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 Aug 2026

## What is GHSA-7mpf-4465-7fc2?

GHSA-7mpf-4465-7fc2 is a cross-site scripting vulnerability in winter/wn-backend-module, published on 20 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

### Impact

`Backend\Widgets\Lists::evalImageTypeValue()` interpolated the resolved image URL into a single-quoted `src` attribute without escaping it. Where a list column of type [`image`](https://wintercms.com/docs/v1.2/docs/backend/lists#image) rendered an attacker-influenced value, that value could break out of the attribute and inject arbitrary attributes — including event handlers — into the backend list, executing in the session of whichever backend user viewed it.

Winter core ships no `image` list column, so a default installation is unaffected. Exploitation requires a plugin that renders attacker-influenced values through one.

The supported [image sources](https://wintercms.com/docs/v1.2/docs/services/image-resizing#available-sources) are plugins, themes, the Media Library, the uploads directory, and `Attach\File` models; an arbitrary external URL is not among them. `ImageResizer::filterGetUrl()` returns the value it was given when it cannot resolve an image, however, so an unsupported value reached the attribute verbatim rather than being rejected.

As with previous issues of this kind the severity is limited: an attacker must already be able to store the value, and a backend user must then open the affected list. Note that validating a stored URL was not necessarily sufficient — a payload can survive `filter_var($url, FILTER_VALIDATE_URL)`, since `/` is valid both in a URL path and after a quoted HTML attribute value.

### Patches

`evalImageTypeValue()` now escapes the image URL, along with the width and height taken from the column configuration, before interpolating them into the tag.

This security issue has been fixed as of **v1.2.14** (commit [`0941c9816181095fe35d58e78e6d0c4a49238967`](https://github.com/wintercms/winter/commit/0941c9816181095fe35d58e78e6d0c4a49238967)).

### Workarounds

Apply the commit above to `modules/backend/widgets/Lists.php` manually if you are unable to upgrade to v1.2.14.

### References

- https://github.com/wintercms/winter/security/advisories/GHSA-43w4-4j3c-jx29
- https://github.com/wintercms/winter/commit/0941c9816181095fe35d58e78e6d0c4a49238967

Credit to Seungyeon Park ([@sy460129](https://github.com/sy460129)) for reporting the issue.

### For more information

If you have any questions or comments about this advisory:
- Email us at [hello@wintercms.com](mailto:hello@wintercms.com)

## Which versions are affected by GHSA-7mpf-4465-7fc2?

2 open source packages ship an affected version, including winter/wn-backend-module.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `winter/wn-backend-module` | Packagist | From 1.1.0 | 1.2.14 |
| `winter/wn-backend-module` | Packagist | From 1.1.0 | 1.2.14 |

## How do I fix GHSA-7mpf-4465-7fc2?

Upgrade winter/wn-backend-module to 1.2.14 or later.

## Is GHSA-7mpf-4465-7fc2 being exploited?

There is no known exploitation of GHSA-7mpf-4465-7fc2 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-7mpf-4465-7fc2 and fix it if it is affected.

What it is: GHSA-7mpf-4465-7fc2 is a cross-site scripting vulnerability in winter/wn-backend-module, published on 20 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of GHSA-7mpf-4465-7fc2 in the wild and no public exploit code.

Affected packages and fixed versions:
- winter/wn-backend-module (Packagist): affected from 1.1.0; fixed in 1.2.14
- winter/wn-backend-module (Packagist): affected from 1.1.0; fixed in 1.2.14

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-7mpf-4465-7fc2/ (Markdown: https://insights.sbomify.com/GHSA-7mpf-4465-7fc2/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-7mpf-4465-7fc2

---
From sbomify Insights: https://insights.sbomify.com/GHSA-7mpf-4465-7fc2/
Summaries are generated and may contain mistakes; the official description above is the record.
