{"answers":{"affected":"2 open source packages ship an affected version, including aiograpi.","exploited":"There is no known exploitation of GHSA-7mw3-79jq-xc7f in the wild and no public exploit code.","fix":"Upgrade aiograpi to 0.7.2 or later.","what":"GHSA-7mw3-79jq-xc7f is a vulnerability in aiograpi, published on 6 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-7mw3-79jq-xc7f and fix it if it is affected.\n\nWhat it is: GHSA-7mw3-79jq-xc7f is a vulnerability in aiograpi, published on 6 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-7mw3-79jq-xc7f in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- aiograpi (PyPI): affected from 0.6.6; fixed in 0.7.2\n- aiograpi (PyPI): affected from 0.6.6; fixed in 0.7.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-7mw3-79jq-xc7f/ (Markdown: https://insights.sbomify.com/GHSA-7mw3-79jq-xc7f/index.md)","id":"GHSA-7mw3-79jq-xc7f","markdown":"https://insights.sbomify.com/GHSA-7mw3-79jq-xc7f/index.md","name":"GHSA-7mw3-79jq-xc7f","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Python API library","requires_auth":"none","summary":"aiograpi incorrectly pins a vulnerable orjson version, allowing denial of service via deeply nested JSON inputs.","user_interaction":"not_required","vuln_class":"supply_chain"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"## Impact\n\naiograpi 0.6.6 / 0.7.0 / 0.7.1 declared `orjson==3.11.6` (and later `==3.11.8`) in `requirements.txt` but `setup.py` carried a hard-coded duplicate `requirements = [...]` list that was never updated and still pinned `orjson==3.11.4`.\n\nWhen `setuptools` builds the source distribution it reads the metadata from `setup.py`, not from `requirements.txt`. So `pip install aiograpi==0.6.6` (or 0.7.0 / 0.7.1) actually pulls `orjson==3.11.4` — a version vulnerable to **CVE-2025-67221** (stack overflow in `orjson.dumps` on deeply nested JSON inputs).\n\n## Practical exploitability\n\nLow in the typical aiograpi flow: `orjson` is used to encode request bodies aiograpi itself constructs and to decode responses returned by Instagram. An attacker would need to coerce aiograpi to encode an attacker-controlled deeply-nested Python structure or to decode an attacker-supplied stream — not the normal call shape.\n\nHowever any caller doing `client.public_request(...)` or similar with caller-controlled payloads, or any caller passing aiograpi-decoded `last_json` into recursive serialization, may hit the unbounded recursion. The patched orjson rejects deeply-nested inputs cleanly.\n\n## Patches\n\nFixed in **aiograpi 0.7.2** by migrating to `pyproject.toml` (PEP 621) — single source of truth for dependencies. PyPI installs of 0.7.2 and later resolve `orjson==3.11.8` correctly.\n\n## Workarounds\n\nForce-install a non-vulnerable orjson alongside the affected aiograpi version:\n\n```\npip install 'aiograpi==0.7.1' 'orjson\u003e=3.11.6'\n```\n\nOr just upgrade to a fixed aiograpi:\n\n```\npip install -U 'aiograpi\u003e=0.7.2'\n```\n\n## Resources\n\n- orjson CVE-2025-67221 advisory: https://github.com/ijl/orjson/security/advisories\n- aiograpi 0.7.2 changelog (security section): https://github.com/subzeroid/aiograpi/blob/main/CHANGELOG.md#072--2026-04-27","ecosystems":["PyPI"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"aiograpi has dependency on vulnerable orjson 3.11.4 (CVE-2025-67221)","id":"GHSA-7mw3-79jq-xc7f","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"supply_chain","year":"2026"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"PyPI","fixed":["0.7.2"],"introduced":["0.6.6"],"last_affected":[],"package":"aiograpi","purl":null,"source":"GHSA-7mw3-79jq-xc7f"},{"ecosystem":"PyPI","fixed":["0.7.2"],"introduced":["0.6.6"],"last_affected":[],"package":"aiograpi","purl":"pkg:pypi/aiograpi","source":"GHSA-7mw3-79jq-xc7f"}],"products":null,"published":"2026-05-06","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"aiograpi incorrectly pins a vulnerable orjson version, allowing denial of service via deeply nested JSON inputs.","url":"https://insights.sbomify.com/GHSA-7mw3-79jq-xc7f/"}