# GHSA-7p79-6x2v-5h88: Server crash if running Python 3.10 w/ Sanic 20.12


- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 16 Feb 2022

## What is GHSA-7p79-6x2v-5h88?

GHSA-7p79-6x2v-5h88 is a vulnerability in sanic, published on 16 Feb 2022. 

### Official description

**!!! ONLY APPLIES TO VERSIONS PRIOR TO Sanic v20.12 WHEN USING Python 3.10 !!!**

Sanic v20.12 officially supports Python versions 3.6, 3.7, 3.8, and 3.9. However, if you accidentally run it with version 3.10 (**which is not supported by Sanic 20.12**), your server is prone to crashing on an incoming web request.

### Impact
Anyone running Sanic server between 0.1.7 and 20.12 **using Python 3.10**.

### Patches
[Sanic v20.12.6](https://github.com/sanic-org/sanic/releases/tag/v20.12.6)

### Workarounds
Use a supported version of Python (v3.6 - v3.9)

### References
> In [asyncio](https://docs.python.org/3/library/asyncio.html#module-asyncio), the explicit passing of a loop argument has been deprecated and will be removed in version 3.10 for the following: ... [asyncio.Event](https://docs.python.org/3/library/asyncio-sync.html#asyncio.Event)

[Python 3.8 Release Notes](https://docs.python.org/3/whatsnew/3.8.html#deprecated)

### For more information
If you have any questions or comments about this advisory:
* Open an issue in [the community forums](https://community.sanicframework.org/)
* Ping us on [the Discord server](https://discord.gg/FARQzAEMAA)

## Which versions are affected by GHSA-7p79-6x2v-5h88?

2 open source packages ship an affected version, including sanic.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sanic` | PyPI | From 0.1.7 | 20.12.6 |
| `sanic` | PyPI | From 0.1.7 | 20.12.6 |

## How do I fix GHSA-7p79-6x2v-5h88?

Upgrade sanic to 20.12.6 or later.

## Is GHSA-7p79-6x2v-5h88 being exploited?

There is no known exploitation of GHSA-7p79-6x2v-5h88 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-7p79-6x2v-5h88 and fix it if it is affected.

What it is: GHSA-7p79-6x2v-5h88 is a vulnerability in sanic, published on 16 Feb 2022. 
Exploitation: There is no known exploitation of GHSA-7p79-6x2v-5h88 in the wild and no public exploit code.

Affected packages and fixed versions:
- sanic (PyPI): affected from 0.1.7; fixed in 20.12.6
- sanic (PyPI): affected from 0.1.7; fixed in 20.12.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-7p79-6x2v-5h88/ (Markdown: https://insights.sbomify.com/GHSA-7p79-6x2v-5h88/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-7p79-6x2v-5h88

---
From sbomify Insights: https://insights.sbomify.com/GHSA-7p79-6x2v-5h88/
Summaries are generated and may contain mistakes; the official description above is the record.
