{"answers":{"affected":"3 open source packages ship an affected version, including github.com/ryanbekhen/nanoproxy.","exploited":"There is no known exploitation of GHSA-7prj-hgx4-2xc3 in the wild and no public exploit code.","fix":"Upgrade github.com/ryanbekhen/nanoproxy to 0.15.0 or later.","what":"GHSA-7prj-hgx4-2xc3 is a vulnerability in github.com/ryanbekhen/nanoproxy, published on 12 Dec 2024."},"fix_prompt":"Check this codebase for GHSA-7prj-hgx4-2xc3 and fix it if it is affected.\n\nWhat it is: GHSA-7prj-hgx4-2xc3 is a vulnerability in github.com/ryanbekhen/nanoproxy, published on 12 Dec 2024. \nExploitation: There is no known exploitation of GHSA-7prj-hgx4-2xc3 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/ryanbekhen/nanoproxy (Go): affected all versions; fixed in 0.15.0\n- github.com/ryanbekhen/nanoproxy (Go): affected all versions; fixed in 0.15.0\n- github.com/ryanbekhen/nanoproxy (Go): affected all versions; fixed in 0.15.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-7prj-hgx4-2xc3/ (Markdown: https://insights.sbomify.com/GHSA-7prj-hgx4-2xc3/index.md)","id":"GHSA-7prj-hgx4-2xc3","markdown":"https://insights.sbomify.com/GHSA-7prj-hgx4-2xc3/index.md","name":"GHSA-7prj-hgx4-2xc3","record":{"aliases":["GO-2024-3330"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass","data_read"],"network_reachable":"unknown","non_default_config":false,"product_category":"Go crypto library","requires_auth":"unknown","summary":"Outdated golang.org/x/crypto dependency in NanoProxy exposes systems to potential authorization bypasses and data breaches, requiring dependency upgrades.","user_interaction":"unknown","vuln_class":"supply_chain"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"A security issue was identified in the NanoProxy project related to the `golang.org/x/crypto` dependency. The project was using an outdated version of this dependency, which potentially exposed the system to security vulnerabilities that have been addressed in subsequent updates.\n\nImpact:\nThe specific vulnerabilities in the outdated version of `golang.org/x/crypto` could include authorization bypasses, data breaches, or other security risks. These vulnerabilities can be exploited by attackers to compromise the integrity, confidentiality, or availability of the system.\n\nResolution:\nThe issue has been fixed in NanoProxy by upgrading the `golang.org/x/crypto` dependency to version 0.31.0. Users are strongly encouraged to update their instances of NanoProxy to include this fix and ensure they are using the latest secure version of all dependencies.\n\nFixed Version:\n* `golang.org/x/crypto` upgraded to version 0.31.0.","ecosystems":["Go"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Potential Vulnerabilities Due to Outdated golang.org/x/crypto Dependency in NanoProxy","id":"GHSA-7prj-hgx4-2xc3","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Go","product":null,"products":[],"type":"supply_chain","year":"2024"},"n_packages":3,"n_references":null,"packages":[{"ecosystem":"Go","fixed":["0.15.0"],"introduced":["0"],"last_affected":[],"package":"github.com/ryanbekhen/nanoproxy","purl":null,"source":"GHSA-7prj-hgx4-2xc3"},{"ecosystem":"Go","fixed":["0.15.0"],"introduced":["0"],"last_affected":[],"package":"github.com/ryanbekhen/nanoproxy","purl":"pkg:golang/github.com/ryanbekhen/nanoproxy","source":"GHSA-7prj-hgx4-2xc3"},{"ecosystem":"Go","fixed":["0.15.0"],"introduced":["0"],"last_affected":[],"package":"github.com/ryanbekhen/nanoproxy","purl":"pkg:golang/github.com/ryanbekhen/nanoproxy","source":"GO-2024-3330"}],"products":null,"published":"2024-12-12","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Outdated golang.org/x/crypto dependency in NanoProxy exposes systems to potential authorization bypasses and data breaches, requiring dependency upgrades.","url":"https://insights.sbomify.com/GHSA-7prj-hgx4-2xc3/"}