# GHSA-7qfm-6m33-rgg9: XML External Entity Reference

> An attacker can exploit XML External Entity vulnerabilities in Report Portal's service-api to disclose secrets and perform Server-Side Request Forgery via JUnit XML imports.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Aug 2021

## What is GHSA-7qfm-6m33-rgg9?

GHSA-7qfm-6m33-rgg9 is a vulnerability in com.epam.reportportal:service-api, published on 13 Aug 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

An issue was discovered in service-api before 4.3.12 and 5.x before 5.1.1 for Report Portal. It allows XXE, with resultant secrets disclosure and SSRF, via JUnit XML launch import.

## Which versions are affected by GHSA-7qfm-6m33-rgg9?

4 open source packages ship an affected version, including com.epam.reportportal:service-api.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.epam.reportportal:service-api` | Maven | All versions | 4.3.12 |
| `com.epam.reportportal:service-api` | Maven | All versions | 4.3.12 |
| `com.epam.reportportal:service-api` | Maven | From 5.0.0 | 5.1.1 |
| `com.epam.reportportal:service-api` | Maven | From 5.0.0 | 5.1.1 |

## How do I fix GHSA-7qfm-6m33-rgg9?

Upgrade com.epam.reportportal:service-api to a fixed version for your release line: 4.3.12 or 5.1.1.

## Is GHSA-7qfm-6m33-rgg9 being exploited?

There is no known exploitation of GHSA-7qfm-6m33-rgg9 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-7qfm-6m33-rgg9 and fix it if it is affected.

What it is: GHSA-7qfm-6m33-rgg9 is a vulnerability in com.epam.reportportal:service-api, published on 13 Aug 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of GHSA-7qfm-6m33-rgg9 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.epam.reportportal:service-api (Maven): affected all versions; fixed in 4.3.12
- com.epam.reportportal:service-api (Maven): affected all versions; fixed in 4.3.12
- com.epam.reportportal:service-api (Maven): affected from 5.0.0; fixed in 5.1.1
- com.epam.reportportal:service-api (Maven): affected from 5.0.0; fixed in 5.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-7qfm-6m33-rgg9/ (Markdown: https://insights.sbomify.com/GHSA-7qfm-6m33-rgg9/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-7qfm-6m33-rgg9

---
From sbomify Insights: https://insights.sbomify.com/GHSA-7qfm-6m33-rgg9/
Summaries are generated and may contain mistakes; the official description above is the record.
