{"answers":{"affected":"2 open source packages ship an affected version, including pusher/pusher-php-server.","exploited":"There is no known exploitation of GHSA-7v7m-pcw5-h3cg in the wild and no public exploit code.","fix":"Upgrade pusher/pusher-php-server to 2.2.1 or later.","what":"GHSA-7v7m-pcw5-h3cg is an authentication bypass vulnerability in pusher/pusher-php-server, published on 20 May 2024. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-7v7m-pcw5-h3cg and fix it if it is affected.\n\nWhat it is: GHSA-7v7m-pcw5-h3cg is an authentication bypass vulnerability in pusher/pusher-php-server, published on 20 May 2024. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-7v7m-pcw5-h3cg in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pusher/pusher-php-server (Packagist): affected all versions; fixed in 2.2.1\n- pusher/pusher-php-server (Packagist): affected all versions; fixed in 2.2.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-7v7m-pcw5-h3cg/ (Markdown: https://insights.sbomify.com/GHSA-7v7m-pcw5-h3cg/index.md)","id":"GHSA-7v7m-pcw5-h3cg","markdown":"https://insights.sbomify.com/GHSA-7v7m-pcw5-h3cg/index.md","name":"GHSA-7v7m-pcw5-h3cg","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Pusher PHP library","requires_auth":"low_privilege","summary":"A malicious user with access to one private channel can forge tokens to access other private channels or authenticate API requests due to insufficient socket_id validation.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"The service offered by Pusher provides \"private\" channels with an authentication mechanism that restricts subscription access. The decision on allowing subscriptions to private channels is delegated to customers, who implement an authentication endpoint. End-users request a token from this endpoint to join a specific channel. The token is an HMAC signature of the end-user's connection ID (socket_id) and the desired channel.\n\nThe issue arises from a lack of validation in the libraries provided to customers. This vulnerability allows a malicious end-user to submit a malformed socket_id field, leading the customer to unknowingly sign a string. This signed string grants access to a different private channel than the one the end-user is ostensibly requesting. Consequently, a malicious end-user, with permission to subscribe to one private channel, can forge permission for any private channel owned by the same customer.\n\nAdditionally, the HTTP API is secured by requiring a signature with each request, generated by the customer's secret key. In specific cases, a malicious end-user may deceive a customer into signing a value for socket_id, effectively authenticating an API request to Pusher.","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Pusher Service Channel Authentication Bypass","id":"GHSA-7v7m-pcw5-h3cg","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"auth_bypass","year":"2024"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["2.2.1"],"introduced":["0"],"last_affected":[],"package":"pusher/pusher-php-server","purl":null,"source":"GHSA-7v7m-pcw5-h3cg"},{"ecosystem":"Packagist","fixed":["2.2.1"],"introduced":["0"],"last_affected":[],"package":"pusher/pusher-php-server","purl":"pkg:composer/pusher/pusher-php-server","source":"GHSA-7v7m-pcw5-h3cg"}],"products":null,"published":"2024-05-20","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"A malicious user with access to one private channel can forge tokens to access other private channels or authenticate API requests due to insufficient socket_id validation.","url":"https://insights.sbomify.com/GHSA-7v7m-pcw5-h3cg/"}