{"answers":{"affected":"2 open source packages ship an affected version, including phpxmlrpc/phpxmlrpc.","exploited":"There is no known exploitation of GHSA-7vcx-v65q-9wpg in the wild and no public exploit code.","fix":"Upgrade phpxmlrpc/phpxmlrpc to 4.9.0 or later.","what":"GHSA-7vcx-v65q-9wpg is a code injection vulnerability in phpxmlrpc/phpxmlrpc, published on 11 Jan 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-7vcx-v65q-9wpg and fix it if it is affected.\n\nWhat it is: GHSA-7vcx-v65q-9wpg is a code injection vulnerability in phpxmlrpc/phpxmlrpc, published on 11 Jan 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-7vcx-v65q-9wpg in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- phpxmlrpc/phpxmlrpc (Packagist): affected all versions; fixed in 4.9.0\n- phpxmlrpc/phpxmlrpc (Packagist): affected all versions; fixed in 4.9.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-7vcx-v65q-9wpg/ (Markdown: https://insights.sbomify.com/GHSA-7vcx-v65q-9wpg/index.md)","id":"GHSA-7vcx-v65q-9wpg","markdown":"https://insights.sbomify.com/GHSA-7vcx-v65q-9wpg/index.md","name":"GHSA-7vcx-v65q-9wpg","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"patch","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"PHP XML-RPC library","requires_auth":"none","summary":"Attackers can inject malicious code if developers use specific wrapper methods with untrusted data or copy debugger output, leading to code execution.","user_interaction":"required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"In order for this weakness to be exploited, the following conditions have to apply, at the same time:\n\n- method `Wrapper::buildClientWrapperCode`, or any methods which depend on it, such as `Wrapper::wrapXmlrpcServer`, `Wrapper::wrapXmlrpcMethod` or `Wrapper::buildWrapMethodSource` must be in use. Note that they are _not_ used by default in either the Client or Server classes provided by the library; the developer has to specifically make use of them in his/her own code\n- the `$client` argument to either of those methods should have been built with malicious data, ie. data controlled by a 3rd party, passed to its constructor call\n\nThis is most likely an uncommon usage scenario, and as such the chances of exploitation may be low.\n\n*NB* the graphical debugger which is shipped as part of the library is vulnerable to this, when used with the option \"Generate stub for method call\" selected. In that case, the debugger will _display_ but not _execute_ the malicious code, which would have to be provided via carefully crafted values for the \"Address\" and \"Path\" inputs.\n\nThe attack scenario in this case is that a developer copies into his/her own source code the php snippet generated by the debugger, in a situation where the debugger is used with \"Address\"/\"Path\" input values supplied by a 3rd party.\nThe malicious payload in the \"Address\"/\"Path\" input values should be easily recognized as suspicious by any barely proficient developer, as it resembles a bog-standard injection attack.\nIt goes without saying that a responsible developer should not blindly copy and paste into his/her own code anything generated by a 3rd party tool, such as the phpxmlrpc debugger, without giving it at least a cursory scan.\n\nOriginally reported as issue #80","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"XML-RPC for PHP's `Wrapper::buildClientWrapperCode` method allows code injection via malicious `$client` argument","id":"GHSA-7vcx-v65q-9wpg","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"code_injection","year":"2023"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["4.9.0"],"introduced":["0"],"last_affected":[],"package":"phpxmlrpc/phpxmlrpc","purl":null,"source":"GHSA-7vcx-v65q-9wpg"},{"ecosystem":"Packagist","fixed":["4.9.0"],"introduced":["0"],"last_affected":[],"package":"phpxmlrpc/phpxmlrpc","purl":"pkg:composer/phpxmlrpc/phpxmlrpc","source":"GHSA-7vcx-v65q-9wpg"}],"products":null,"published":"2023-01-11","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can inject malicious code if developers use specific wrapper methods with untrusted data or copy debugger output, leading to code execution.","url":"https://insights.sbomify.com/GHSA-7vcx-v65q-9wpg/"}