GHSA-7vpr-3ppw-qrpj Imageflow affected by libwebp zero-day and should not be used with malicious source images.

Not scored Published

Imageflow is vulnerable to remote code execution via malicious WebP images due to a libwebp out-of-bounds write flaw.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is GHSA-7vpr-3ppw-qrpj?

GHSA-7vpr-3ppw-qrpj is a memory corruption vulnerability in ImageResizer.Plugins.Imageflow, published on 27 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Impact

This vulnerability affects deployments of Imageflow that involve decoding or processing malicious source .webp files. If you only process your own trusted files, this should not affect you (but you should update anyway).

Imageflow relies on Google's [libwebp] library to decode .webp images, and is affected by the recent zero-day out-of-bounds write vulnerability CVE-2023-4863 and https://github.com/advisories/GHSA-j7hp-h8jx-5ppr. The libwebp vulnerability also affects Chrome, Android, macOS, and other consumers of the library).

libwebp patched the vulnerability and released 1.3.2

This was patched in libwebp-sys in 0.9.3 and 0.9.4

Imageflow v2.0.0-preview8 uses the patched version of libwebp as well as updated versions of all dependencies.

Note: preview 8 requires libc 2.31 or higher on linux and macOS 11 or higher. These restrictions are due to the oldest supported versions of those platforms (which is reflected on Github Actions).

Patches

Imageflow v2.0.0-preview8 use the patched version (v1.3.2) of libwebp and libwebp-sys 0.9.4. Imageflow.AllPlatforms 0.10.2 is patched Imageflow.Server v0.8.2 is patched ImageResizer.Plugins.Imageflow 5.0.12 is patched

Workarounds

Disable webp decoding using EnabledCodecs::disable_decoder(NamedDecoders::WebPDecoder) if using the Rust API.

Only files that meet the following criteria will be passed to libwebp:

bytes.starts_with(b"RIFF") && bytes[8..12].starts_with(b"WEBP")

You can utilize matching logic to block webp inputs in your language of choice.

References

https://github.com/advisories/GHSA-j7hp-h8jx-5ppr https://nvd.nist.gov/vuln/detail/CVE-2023-4863 https://github.com/webmproject/libwebp/commit/2af26267cdfcb63a88e5c74a85927a12d6ca1d76 https://github.com/NoXF/libwebp-sys/commits/master

Which versions are affected by GHSA-7vpr-3ppw-qrpj?

40 open source packages ship an affected version, including ImageResizer.Plugins.Imageflow, Imageflow.AllPlatforms and Imageflow.NativeRuntime.osx-x86_64.

PackageAffectedFixed in
ImageResizer.Plugins.Imageflow NuGetAll versions5.0.12
ImageResizer.Plugins.Imageflow NuGetAll versions5.0.12
Imageflow.AllPlatforms NuGetAll versions0.10.2
Imageflow.AllPlatforms NuGetAll versions0.10.2
Imageflow.NativeRuntime.osx-x86_64 NuGetAll versions2.0.0-preview6
Imageflow.NativeRuntime.osx-x86_64 NuGetAll versions2.0.0-preview6
34 more packages
Imageflow.NativeRuntime.osx_10_11-x86_64 NuGetAll versionsNone
Imageflow.NativeRuntime.osx_10_11-x86_64 NuGetAll versionsNone
Imageflow.NativeRuntime.ubuntu-x86_64 NuGetAll versions2.0.0-preview6
Imageflow.NativeRuntime.ubuntu-x86_64 NuGetAll versions2.0.0-preview6
Imageflow.NativeRuntime.ubuntu-x86_64-haswell NuGetAll versions2.0.0-preview6
Imageflow.NativeRuntime.ubuntu-x86_64-haswell NuGetAll versions2.0.0-preview6
Imageflow.NativeRuntime.ubuntu_16_04-x86_64 NuGetAll versionsNone
Imageflow.NativeRuntime.ubuntu_16_04-x86_64 NuGetAll versionsNone
Imageflow.NativeRuntime.ubuntu_18_04-x86_64 NuGetAll versionsNone
Imageflow.NativeRuntime.ubuntu_18_04-x86_64 NuGetAll versionsNone
Imageflow.NativeRuntime.ubuntu_18_04-x86_64-haswell NuGetAll versionsNone
Imageflow.NativeRuntime.ubuntu_18_04-x86_64-haswell NuGetAll versionsNone
Imageflow.NativeRuntime.win-x86 NuGetAll versions2.0.0-preview6
Imageflow.NativeRuntime.win-x86 NuGetAll versions2.0.0-preview6
Imageflow.NativeRuntime.win-x86_64 NuGetAll versions2.0.0-preview6
Imageflow.NativeRuntime.win-x86_64 NuGetAll versions2.0.0-preview6
Imageflow.NativeTool.osx-x86_64 NuGetAll versions2.0.0-preview6
Imageflow.NativeTool.osx-x86_64 NuGetAll versions2.0.0-preview6
Imageflow.NativeTool.osx_10_11-x86_64 NuGetAll versionsNone
Imageflow.NativeTool.osx_10_11-x86_64 NuGetAll versionsNone
Imageflow.NativeTool.ubuntu-x86_64 NuGetAll versions2.0.0-preview6
Imageflow.NativeTool.ubuntu-x86_64 NuGetAll versions2.0.0-preview6
Imageflow.NativeTool.ubuntu-x86_64-haswell NuGetAll versions2.0.0-preview6
Imageflow.NativeTool.ubuntu-x86_64-haswell NuGetAll versions2.0.0-preview6
Imageflow.NativeTool.ubuntu_16_04-x86_64 NuGetAll versionsNone
Imageflow.NativeTool.ubuntu_16_04-x86_64 NuGetAll versionsNone
Imageflow.NativeTool.ubuntu_18_04-x86_64 NuGetAll versionsNone
Imageflow.NativeTool.ubuntu_18_04-x86_64 NuGetAll versionsNone
Imageflow.NativeTool.ubuntu_18_04-x86_64-haswell NuGetAll versionsNone
Imageflow.NativeTool.ubuntu_18_04-x86_64-haswell NuGetAll versionsNone
Imageflow.NativeTool.win-x86 NuGetAll versions2.0.0-preview6
Imageflow.NativeTool.win-x86 NuGetAll versions2.0.0-preview6
Imageflow.NativeTool.win-x86_64 NuGetAll versions2.0.0-preview6
Imageflow.NativeTool.win-x86_64 NuGetAll versions2.0.0-preview6

How do I fix GHSA-7vpr-3ppw-qrpj?

Upgrade ImageResizer.Plugins.Imageflow to 5.0.12 or later.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is GHSA-7vpr-3ppw-qrpj being exploited?

There is no known exploitation of GHSA-7vpr-3ppw-qrpj in the wild and no public exploit code.

Sources

Is GHSA-7vpr-3ppw-qrpj in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free