# GHSA-7ww3-xvf5-cxwm: ciguard: Web UI is missing HTTP defence-in-depth headers

> Missing HTTP security headers in ciguard's web UI allow clickjacking and reduce XSS defenses, requiring a patch to add defense-in-depth headers.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 5 May 2026

## What is GHSA-7ww3-xvf5-cxwm?

GHSA-7ww3-xvf5-cxwm is a vulnerability in ciguard, published on 5 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

## Summary

ciguard's FastAPI Web UI (`src/ciguard/web/app.py`) does not set HTTP defence-in-depth headers. OWASP ZAP baseline scan flagged 11 alerts: missing Content-Security-Policy (Medium), X-Frame-Options (Medium), Sub-Resource-Integrity on `/api/docs` (Medium), COOP / COEP / CORP (Low), Permissions-Policy (Low), X-Content-Type-Options (Low).

## Threat scenario

For local-only deployment (current intent): minimal — there's no untrusted browser context, no third-party hosting, no auth surface to protect.

For public hosting (PRD Slice 9 GitHub App or hosted dashboard, future): each missing header reduces a defence layer:

- Missing CSP → injected XSS would have no second-line defence (first-line Jinja autoescape remains intact)
- Missing X-Frame-Options → clickjacking against any UI button would be possible
- Missing SRI on jsdelivr-hosted Swagger UI → if jsdelivr were compromised, attacker JS would run in the docs page context

## Patch

- New `SecurityHeadersMiddleware` at `src/ciguard/web/security_headers.py` injecting: X-Content-Type-Options nosniff, X-Frame-Options DENY, Referrer-Policy no-referrer, Permissions-Policy `interest-cohort=()`, Cross-Origin-Opener-Policy same-origin, Cross-Origin-Resource-Policy same-origin, plus per-path CSP with `/api/docs` + `/api/redoc` carve-out for cdn.jsdelivr.net (Swagger UI / ReDoc dependency).
- COEP intentionally NOT set: would break Swagger UI's cross-origin assets, and ciguard makes no SharedArrayBuffer use that would benefit.
- Registered via `app.add_middleware(SecurityHeadersMiddleware)`.
- 6 regression tests in `tests/test_web.py::TestSecurityHeaders`.

## Discovery

Found by OWASP ZAP baseline scan during ciguard's first self-conducted pentest cycle, 2026-04-26.

## CVSS Scoring

- CVSS v3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N` — 4.3 (Medium per v3.1 thresholds)
- CVSS v4.0: `CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N` — first.org calc 4.3 (Low); GitHub's calc 2.1 (Low). All consistent at Low/borderline.

## Verification

```
$ curl -sI http://127.0.0.1:8080/ | grep -E '^(X-Frame|X-Content|Referrer|Permissions|Cross-Origin|Content-Security):'
# Pre-fix: empty
# Post-fix: 7 headers present
```

## Resources

- Fix released in [v0.8.2](https://github.com/Jo-Jo98/ciguard/releases/tag/v0.8.2)
- CI regression gate added in [v0.8.3](https://github.com/Jo-Jo98/ciguard/releases/tag/v0.8.3)

## Which versions are affected by GHSA-7ww3-xvf5-cxwm?

2 open source packages ship an affected version, including ciguard.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ciguard` | PyPI | From 0.1.0 | 0.8.2 |
| `ciguard` | PyPI | From 0.1.0 | 0.8.2 |

## How do I fix GHSA-7ww3-xvf5-cxwm?

Upgrade ciguard to 0.8.2 or later.

## Is GHSA-7ww3-xvf5-cxwm being exploited?

There is no known exploitation of GHSA-7ww3-xvf5-cxwm in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-7ww3-xvf5-cxwm and fix it if it is affected.

What it is: GHSA-7ww3-xvf5-cxwm is a vulnerability in ciguard, published on 5 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of GHSA-7ww3-xvf5-cxwm in the wild and no public exploit code.

Affected packages and fixed versions:
- ciguard (PyPI): affected from 0.1.0; fixed in 0.8.2
- ciguard (PyPI): affected from 0.1.0; fixed in 0.8.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-7ww3-xvf5-cxwm/ (Markdown: https://insights.sbomify.com/GHSA-7ww3-xvf5-cxwm/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-7ww3-xvf5-cxwm

---
From sbomify Insights: https://insights.sbomify.com/GHSA-7ww3-xvf5-cxwm/
Summaries are generated and may contain mistakes; the official description above is the record.
