# GHSA-7wwv-vh3v-89cq: ReDOS vulnerabities: multiple grammars

> Attackers can cause denial of service via exponential regex backtracking in specific grammars when highlighting user-provided data.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Dec 2020

## What is GHSA-7wwv-vh3v-89cq?

GHSA-7wwv-vh3v-89cq is a denial of service vulnerability in @highlightjs/cdn-assets, published on 4 Dec 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

### Impact: Potential ReDOS vulnerabilities (exponential and polynomial RegEx backtracking)

[oswasp](https://owasp.org/www-community/attacks/Regular_expression_Denial_of_Service_-_ReDoS): 

> The Regular expression Denial of Service (ReDoS) is a Denial of Service attack, that exploits the fact that most Regular Expression implementations may reach extreme situations that cause them to work very slowly (exponentially related to input size). An attacker can then cause a program using a Regular Expression to enter these extreme situations and then hang for a very long time.

If are you are using Highlight.js to highlight user-provided data you are possibly vulnerable.  On the client-side (in a browser or Electron environment) risks could include lengthy freezes or crashes... On the server-side infinite freezes could occur... effectively preventing users from accessing your app or service (ie, Denial of Service).

This is an issue with grammars shipped with the parser (and potentially 3rd party grammars also), not the parser itself. If you are using Highlight.js with any of the following grammars you are vulnerable.  If you are using `highlightAuto` to detect the language (and have any of these grammars registered) you are vulnerable. Exponential grammars (C, Perl, JavaScript) are auto-registered when using the common grammar subset/library `require('highlight.js/lib/common')` as of 10.4.0 - see https://cdn.jsdelivr.net/gh/highlightjs/cdn-release@10.4.0/build/highlight.js

All versions prior to 10.4.1 are vulnerable, including version 9.18.5. 

**Grammars with exponential backtracking issues:**

  - c-like (c, cpp, arduino)
  - handlebars (htmlbars)
  - gams
  - perl
  - jboss-cli
  - r
  - erlang-repl
  - powershell
  - routeros
  - livescript (10.4.0 and 9.18.5 included this fix)
  - javascript & typescript (10.4.0 included partial fixes)

And of course any aliases of those languages have the same issue. ie: `hpp` is no safer than `cpp`.

**Grammars with polynomial backtracking issues:**

- kotlin
- gcode
- d
- aspectj
- moonscript
- coffeescript/livescript
- csharp
- scilab
- crystal
- elixir
- basic
- ebnf
- ruby
- fortran/irpf90
- livecodeserver
- yaml
- x86asm
- dsconfig
- markdown
- ruleslanguage
- xquery
- sqf

And again: any aliases of those languages have the same issue. ie: `ruby` and `rb` share the same ruby issues.

### Patches

- Version 10.4.1 resolves these vulnerabilities.  Please upgrade.

### Workarounds / Mitigations

- Discontinue use the affected grammars. (or perhaps use only those with poly vs exponential issues)
- Attempt cherry-picking the grammar fixes into older versions...
- Attempt using newer CDN versions of any affected languages.  (ie using an older CDN version of the library with newer CDN grammars).  Your mileage may vary.

### References

- https://owasp.org/www-community/attacks/Regular_expression_Denial_of_Service_-_ReDoS

### For more information

If you have any questions or comments about this advisory:
* Open an issue: https://github.com/highlightjs/highlight.js/issues
* Email us at [security@highlightjs.com](mailto:security@highlightjs.com)

## Which versions are affected by GHSA-7wwv-vh3v-89cq?

4 open source packages ship an affected version, including @highlightjs/cdn-assets and highlight.js.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@highlightjs/cdn-assets` | npm | All versions | 10.4.1 |
| `@highlightjs/cdn-assets` | npm | All versions | 10.4.1 |
| `highlight.js` | npm | From 9.0.0 | 10.4.1 |
| `highlight.js` | npm | From 9.0.0 | 10.4.1 |

## How do I fix GHSA-7wwv-vh3v-89cq?

Upgrade @highlightjs/cdn-assets to 10.4.1 or later.

## Is GHSA-7wwv-vh3v-89cq being exploited?

There is no known exploitation of GHSA-7wwv-vh3v-89cq in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-7wwv-vh3v-89cq and fix it if it is affected.

What it is: GHSA-7wwv-vh3v-89cq is a denial of service vulnerability in @highlightjs/cdn-assets, published on 4 Dec 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-7wwv-vh3v-89cq in the wild and no public exploit code.

Affected packages and fixed versions:
- @highlightjs/cdn-assets (npm): affected all versions; fixed in 10.4.1
- @highlightjs/cdn-assets (npm): affected all versions; fixed in 10.4.1
- highlight.js (npm): affected from 9.0.0; fixed in 10.4.1
- highlight.js (npm): affected from 9.0.0; fixed in 10.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-7wwv-vh3v-89cq/ (Markdown: https://insights.sbomify.com/GHSA-7wwv-vh3v-89cq/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-7wwv-vh3v-89cq

---
From sbomify Insights: https://insights.sbomify.com/GHSA-7wwv-vh3v-89cq/
Summaries are generated and may contain mistakes; the official description above is the record.
