{"answers":{"affected":"2 open source packages ship an affected version, including json-serializer.","exploited":"There is no known exploitation of GHSA-7xfq-xh6v-4mrm in the wild and no public exploit code.","fix":"Upgrade json-serializer to 2.0.11 or later.","what":"GHSA-7xfq-xh6v-4mrm is a vulnerability in json-serializer, published on 1 Sep 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-7xfq-xh6v-4mrm and fix it if it is affected.\n\nWhat it is: GHSA-7xfq-xh6v-4mrm is a vulnerability in json-serializer, published on 1 Sep 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-7xfq-xh6v-4mrm in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- json-serializer (npm): affected from 2.0.10; fixed in 2.0.11\n- json-serializer (npm): affected from 2.0.10; fixed in 2.0.11\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-7xfq-xh6v-4mrm/ (Markdown: https://insights.sbomify.com/GHSA-7xfq-xh6v-4mrm/index.md)","id":"GHSA-7xfq-xh6v-4mrm","markdown":"https://insights.sbomify.com/GHSA-7xfq-xh6v-4mrm/index.md","name":"GHSA-7xfq-xh6v-4mrm","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"npm JavaScript library","requires_auth":"none","summary":"A malicious npm package version steals sensitive form data like passwords and credit card numbers from browser users.","user_interaction":"required","vuln_class":"supply_chain"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Version 2.0.10 of `json-serializer` contained malicious code. The code when executed in the browser would enumerate password, cvc, cardnumber fields from forms and send the extracted values to `https://js-metrics.com/minjs.php?pl=`\n\n## Recommendation\n\nIf version 2.0.10 of this module is found installed you will want to replace it with a version before or after 2.0.10. In addition to replacing the installed module, you will also want to evaluate your application to determine whether or not user data was compromised.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Malicious Package in json-serializer","id":"GHSA-7xfq-xh6v-4mrm","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"supply_chain","year":"2020"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["2.0.11"],"introduced":["2.0.10"],"last_affected":[],"package":"json-serializer","purl":null,"source":"GHSA-7xfq-xh6v-4mrm"},{"ecosystem":"npm","fixed":["2.0.11"],"introduced":["2.0.10"],"last_affected":[],"package":"json-serializer","purl":"pkg:npm/json-serializer","source":"GHSA-7xfq-xh6v-4mrm"}],"products":null,"published":"2020-09-01","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"A malicious npm package version steals sensitive form data like passwords and credit card numbers from browser users.","url":"https://insights.sbomify.com/GHSA-7xfq-xh6v-4mrm/"}