{"answers":{"affected":"3 open source packages ship an affected version, including github.com/karmada-io/karmada.","exploited":"There is no known exploitation of GHSA-7xg2-83f8-39mr in the wild and no public exploit code.","fix":"Upgrade github.com/karmada-io/karmada to 1.8.0 or later.","what":"GHSA-7xg2-83f8-39mr is a vulnerability in github.com/karmada-io/karmada, published on 3 Jan 2024."},"fix_prompt":"Check this codebase for GHSA-7xg2-83f8-39mr and fix it if it is affected.\n\nWhat it is: GHSA-7xg2-83f8-39mr is a vulnerability in github.com/karmada-io/karmada, published on 3 Jan 2024. \nExploitation: There is no known exploitation of GHSA-7xg2-83f8-39mr in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/karmada-io/karmada (Go): affected all versions; fixed in 1.8.0\n- github.com/karmada-io/karmada (Go): affected all versions; fixed in 1.8.0\n- github.com/karmada-io/karmada (Go): affected all versions; fixed in 1.8.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-7xg2-83f8-39mr/ (Markdown: https://insights.sbomify.com/GHSA-7xg2-83f8-39mr/index.md)","id":"GHSA-7xg2-83f8-39mr","markdown":"https://insights.sbomify.com/GHSA-7xg2-83f8-39mr/index.md","name":"GHSA-7xg2-83f8-39mr","record":{"aliases":["GO-2024-2441"],"analysis":null,"analysis_generated_by":null,"assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\n_What kind of vulnerability is it? Who is impacted?_\n\nThe Karmada components deployed with `karmadactl`, `karma-operator`, and `helm chart` take Golang default cipher suites as part of the TLS protocol, which includes the insecure algorithm. Referring to https://github.com/golang/go/issues/41476#issuecomment-694914728, the 3DES algorithm vulnerability is very unlikely to be attacked. However, to address the concerns and to avoid being disturbed by the security scanner, Karmada has decided to limit the cipher suites to exclude the insecure 3DES algorithm and accordingly release this security advisory.\n\nThe components affected are：\n- karmada-apiserver\n- karmada-aggregated-apiserver\n- karmada-search\n- karmada-metrics-adapter\n- etcd\n\n### Patches\n_Has the problem been patched? What versions should users upgrade to?_\n\nFrom Karmada v1.8.0, when deploying Karmada with `karmadactl`, `karma-operator`, and `helm chart`, the default minimum TLS version of components(include `karmada-apiserver`, `karmada-aggregated-apiserver`, `karmada-search`, and `karmada-metrics-adapter`) would be set to `TLS1.3` to get rid of the insecure algorithm, and set default cipher suites(`TLS_RSA_WITH_AES_128_CBC_SHA,TLS_RSA_WITH_AES_256_CBC_SHA,TLS_RSA_WITH_AES_128_GCM_SHA256,TLS_RSA_WITH_AES_256_GCM_SHA384,TLS_AES_128_GCM_SHA256,TLS_AES_256_GCM_SHA384,TLS_CHACHA20_POLY1305_SHA256,TLS_ECDHE_ECDSA_WITH_AES_128_CBC_SHA,TLS_ECDHE_ECDSA_WITH_AES_256_CBC_SHA,TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA,TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA,TLS_ECDHE_ECDSA_WITH_AES_128_GCM_SHA256,TLS_ECDHE_ECDSA_WITH_AES_256_GCM_SHA384,TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256,TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384,TLS_ECDHE_RSA_WITH_CHACHA20_POLY1305_SHA256,TLS_ECDHE_ECDSA_WITH_CHACHA20_POLY1305_SHA256,TLS_ECDHE_RSA_WITH_CHACHA20_POLY1305,TLS_ECDHE_ECDSA_WITH_CHACHA20_POLY1305`) for `etcd`.\n\n### Workarounds\n_Is there a way for users to fix or remediate the vulnerability without upgrading?_\n\nBy setting the `--tls-min-version` for the affected components to TLS 1.3, or explicitly setting the `--cipher-suites` to secure algorithms.\n\n### References\n_Are there any links users can visit to find out more?_\n\n1. Enhancements made from the Karmada community: https://github.com/karmada-io/karmada/issues/4191\n2. Impact discussions from the Golang community: https://github.com/golang/go/issues/41476","ecosystems":["Go"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"The DES/3DES cipher was used as part of the TLS protocol by installation tools","id":"GHSA-7xg2-83f8-39mr","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Go","product":null,"products":[],"type":null,"year":"2024"},"n_packages":3,"n_references":null,"packages":[{"ecosystem":"Go","fixed":["1.8.0"],"introduced":["0"],"last_affected":[],"package":"github.com/karmada-io/karmada","purl":null,"source":"GHSA-7xg2-83f8-39mr"},{"ecosystem":"Go","fixed":["1.8.0"],"introduced":["0"],"last_affected":[],"package":"github.com/karmada-io/karmada","purl":"pkg:golang/github.com/karmada-io/karmada","source":"GHSA-7xg2-83f8-39mr"},{"ecosystem":"Go","fixed":["1.8.0"],"introduced":["0"],"last_affected":[],"package":"github.com/karmada-io/karmada","purl":"pkg:golang/github.com/karmada-io/karmada","source":"GO-2024-2441"}],"products":null,"published":"2024-01-03","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":null,"url":"https://insights.sbomify.com/GHSA-7xg2-83f8-39mr/"}