{"answers":{"affected":"2 open source packages ship an affected version, including software.amazon.jdbc:aws-advanced-jdbc-wrapper.","exploited":"There is no known exploitation of GHSA-7xw4-g7mm-r4hh in the wild and no public exploit code.","fix":"Upgrade software.amazon.jdbc:aws-advanced-jdbc-wrapper to 2.6.5 or later.","what":"GHSA-7xw4-g7mm-r4hh is a vulnerability in software.amazon.jdbc:aws-advanced-jdbc-wrapper, published on 13 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-7xw4-g7mm-r4hh and fix it if it is affected.\n\nWhat it is: GHSA-7xw4-g7mm-r4hh is a vulnerability in software.amazon.jdbc:aws-advanced-jdbc-wrapper, published on 13 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-7xw4-g7mm-r4hh in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- software.amazon.jdbc:aws-advanced-jdbc-wrapper (Maven): affected all versions; fixed in 2.6.5\n- software.amazon.jdbc:aws-advanced-jdbc-wrapper (Maven): affected all versions; fixed in 2.6.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-7xw4-g7mm-r4hh/ (Markdown: https://insights.sbomify.com/GHSA-7xw4-g7mm-r4hh/index.md)","id":"GHSA-7xw4-g7mm-r4hh","markdown":"https://insights.sbomify.com/GHSA-7xw4-g7mm-r4hh/index.md","name":"GHSA-7xw4-g7mm-r4hh","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"AWS JDBC Wrapper","requires_auth":"low_privilege","summary":"A low-privilege user can escalate privileges to rds_superuser in Aurora PostgreSQL via a crafted function in the AWS JDBC Wrapper.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Description of Vulnerability:\nAn issue in AWS Wrappers for Amazon Aurora PostgreSQL may allow for privilege escalation to rds_superuser role. A low privilege authenticated user can create a crafted function that could be executed with permissions of other Amazon Relational Database Service (RDS) users.\n\nAWS recommends for customers to upgrade to the following versions: AWS JDBC Wrapper to v2.6.5 or greater.\n\n### Source of Vulnerability Report: \nAllistair Ishmael Hakim [allistair.hakim@gmail.com](mailto:allistair.hakim@gmail.com)\n\n### Affected products \u0026 versions: \nAWS JDBC Wrapper \u003c 2.6.5\n\n### Platforms: \nMacOS/Windows/Linux","ecosystems":["Maven"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Amazon Web Services Advanced JDBC Wrapper: Privilege Escalation in Aurora PostgreSQL instance","id":"GHSA-7xw4-g7mm-r4hh","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Maven","product":null,"products":[],"type":"privilege_escalation","year":"2025"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Maven","fixed":["2.6.5"],"introduced":["0"],"last_affected":[],"package":"software.amazon.jdbc:aws-advanced-jdbc-wrapper","purl":null,"source":"GHSA-7xw4-g7mm-r4hh"},{"ecosystem":"Maven","fixed":["2.6.5"],"introduced":["0"],"last_affected":[],"package":"software.amazon.jdbc:aws-advanced-jdbc-wrapper","purl":"pkg:maven/software.amazon.jdbc/aws-advanced-jdbc-wrapper","source":"GHSA-7xw4-g7mm-r4hh"}],"products":null,"published":"2025-11-13","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"A low-privilege user can escalate privileges to rds_superuser in Aurora PostgreSQL via a crafted function in the AWS JDBC Wrapper.","url":"https://insights.sbomify.com/GHSA-7xw4-g7mm-r4hh/"}